Chapter 1
The ArcGIS platform

Tutorial 1-1: Overview of ArcGIS Pro

Turn layers on and off

Page 8, step 1
In the Contents pane, scroll down to see the legend for Population Density.
The correct image is as follows:

Examine the Catalog pane, and open and export a map layout

Page 10, step 2
In the Catalog pane, click the arrows to the left of the Maps and Layouts folders to expand the folders—revealing what’s been built so far for this project.
The correct image is as follows:
Pages 10 and 11, step 3

In the Catalog pane under Layouts, double-click FQHC and MedExpress Clinics.

The correct image is as follows:

**Poverty Areas and Population Density by Census Tract in Allegheny County, Pennsylvania**

---

Page 11, step 5

On the Layout tab, in the Navigate group, click the Full Extent Button.

The correct button image is as follows:
Page 12, YOUR TURN

The correct image is as follows:

**Poverty Areas and Population Density by Census Tract in Allegheny County, Pennsylvania**

---

**Tutorial 1-2: Navigate ArcGIS Pro**

**Use a pop-up window**

**Page 13, step 3**

Click the pop-up’s website hyperlink, and when you finish, close your browser.

The correct image is as follows:

<table>
<thead>
<tr>
<th>Private-sector health care</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
</tr>
<tr>
<td>Address</td>
</tr>
<tr>
<td>City</td>
</tr>
<tr>
<td>State</td>
</tr>
<tr>
<td>ZIP</td>
</tr>
<tr>
<td>Code</td>
</tr>
</tbody>
</table>
Search for a feature

Page 18, step 4

**Click the Add Clause button.**

The correct step text is as follows:

**Click the New Expression button.**

Delete the current Add Clause button image.

Page 18, step 5

**Make your selections as seen in the following graphic.**

The correct image is as follows:

| Where | NAME * | Is equal to | McKees Rocks | X |

Page 18, step 6

**Click Add, and then click the Run button. When the run completes, close the Geoprocessing pane.**

The correct step text is as follows:

**Click the Run button. When the run completes, close the Geoprocessing pane.**

Page 18, step 9

**At the top of the table, click the Clear Selection button.**

The correct button image is as follows: 

---

**Tutorial 1-3: Work with attribute data**

**Open and sort attribute tables**

Page 19, step 1

**In the Contents pane, right-click MedExpress Clinics, and click Attribute Table.**

The correct image is as follows:

<table>
<thead>
<tr>
<th>OBJECTID</th>
<th>Shape</th>
<th>Name</th>
<th>Address</th>
<th>City</th>
<th>State</th>
<th>ZIP Code</th>
<th>Latitude</th>
<th>Longitude</th>
<th>Website</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Point</td>
<td>Med Express</td>
<td>4655 William Flynn H... Allison Park</td>
<td>PA</td>
<td>15101</td>
<td>40.591454</td>
<td>-79.548107</td>
<td></td>
<td><a href="http://www.medexpress.com/local">http://www.medexpress.com/local</a>...</td>
</tr>
<tr>
<td>2</td>
<td>Point</td>
<td>Med Express</td>
<td>3024 Washington Pike Bridgeville</td>
<td>PA</td>
<td>15017</td>
<td>40.353313</td>
<td>-80.115109</td>
<td></td>
<td><a href="http://www.medexpress.com/abo">http://www.medexpress.com/abo</a>...</td>
</tr>
<tr>
<td>3</td>
<td>Point</td>
<td>Med Express</td>
<td>2644 Moss Side Blvd #... Monroeville</td>
<td>PA</td>
<td>15146</td>
<td>40.43207</td>
<td>-79.751309</td>
<td></td>
<td><a href="http://www.medexpress.com/local">http://www.medexpress.com/local</a>...</td>
</tr>
<tr>
<td>4</td>
<td>Point</td>
<td>Med Express</td>
<td>1535 Washington Rd Pittsburgh</td>
<td>PA</td>
<td>15228</td>
<td>40.357001</td>
<td>-80.050376</td>
<td></td>
<td>&lt;Null&gt;</td>
</tr>
<tr>
<td>5</td>
<td>Point</td>
<td>Med Express Urgent...</td>
<td>8702 University Blvd Coraopolis</td>
<td>PA</td>
<td>15108</td>
<td>40.50613</td>
<td>-80.223608</td>
<td></td>
<td><a href="http://www.medexpress.com/local">http://www.medexpress.com/local</a>...</td>
</tr>
<tr>
<td>6</td>
<td>Point</td>
<td>Med Express Urgent...</td>
<td>2600 Old Washington... Pittsburgh</td>
<td>PA</td>
<td>15241</td>
<td>40.310486</td>
<td>-80.090711</td>
<td></td>
<td><a href="http://www.medexpress.com/local">http://www.medexpress.com/local</a>...</td>
</tr>
</tbody>
</table>
Select records and features of a map feature class

Page 23, step 2

In the table on the left of row 1, click the square gray cell, press and hold your mouse button, and drag down through row 6.

The correct image is as follows:

Page 24, step 8

Press the Shift key, and on the map individually select any five FQHCs.

The correct step text is as follows:

Press the Ctrl key, and on the map individually select any five FQHCs.

Page 24, step 11

At the top of the table, click the Switch Selection button.

The correct button image is as follows: ⬈️Switch
Get summary statistics using a tool

Page 25, step 3

Expand Analysis Tools > Statistics.

The correct image is as follows:

Page 26, step 5

In Summary Statistics, choose your selections as shown in the following figure to get the statistics for PopDensity of the Population Density feature class.

The correct step text and note text are as follows:

In Summary Statistics, choose your selections as shown in the following figure to get the statistics for PopDensity of the Population Density feature class. Type AllCoTracts_Statistics for the Output Table.

ArcGIS Pro automatically chooses your project’s default file geodatabase, Chapter 1.gdb, for the output table. Make sure that the Case field is clear. If it’s not clear, point to the left of the field and click the red X.

The correct image is as follows:
Tutorial 1-4: Symbolize maps

Symbolize feature classes

Page 28, YOUR TURN

A correct image is as follows:

Label a feature class

Page 29, step 5

Click the Text Symbol button, change the font to size 7, and select a dark-gray color.

There is no Text Symbol button. Delete the button image.

The correct step text is as follows:

In the Text Symbol group, change the font to size 7, and select a dark-gray color.

Page 29, step 6

Click the Text Symbol button again, and in the lower-right corner of the text window, click the Dialog Launcher button.

The correct step text is as follows:

In the Text Symbol Group, in the lower-right corner, click the Dialog Launcher button.
Page 29, step 7
In the Label Class pane, scroll down if necessary, click Halo > the white square for Halo, symbol > No Color for Outline color, and for Halo size type 0.75 pt.

The correct step text is as follows:
In the Label Class pane, click Symbol, scroll down if necessary, click Halo > the white square for Halo, symbol > No Color for Outline color, and for Halo size type 0.75 pt.

Tutorial 1-5: Publishing maps to ArcGIS Online
Share your map online
Page 33, step 1
Open Tutorial1-5.

The correct image is as follows:
Page 34, step 8
In the Share Web Map pane, replace Your_Name, as seen in the graphic that follows, with your name or student ID.

The correct image is as follows:

---

Open your map in ArcGIS Online

Page 35, step 2
Sign in with your ArcGIS organizational account and click My Content.

The correct step text is as follows:
Sign in with your ArcGIS organizational account and click Content.

The correct image is as follows:
Share and open your map

Page 36, step 3

In the first row of the list with type, Web Map, click the arrow on the right of Health_Care_Clinics_Your_Name, and click Open in map viewer.

The correct image is as follows:
Review functionality available for feature layers

Page 36, step 2

Click the More Options button.

The correct image is as follows:

Configure pop-ups

Page 38, step 8

Click OK.

The correct step text is as follows:

Select ZIP Code, unselect Use 1000 Separator, and click OK.

Use a pop-up

Page 38, step 1

Click the westmost MedExpress Urgent Care facility to see its pop-up.

The correct image is as follows:
Use your map

Page 40, step 1

Click the Show Legend button.

The correct step text is as follows:

Click the Show Map Legend button.

Tutorial 1-6: Use Explorer for ArcGIS on your tablet or smartphone

Open your map

Page 42, step 1

At the top left of your screen, select the menu (three horizontal lines).

Delete this step. It is no longer needed.

Page 43, step 2

In the Account section, select My maps, select your ID, and select your Health_Care_Clinics map.

The correct step text is as follows:

Select your Health_Care_Clinics map.

Page 43, step 3

Using usual gestures, zoom into your map.

The correct image is as follows:
Chapter 2
Map design

Tutorial 2-1: Choropleth maps for qualitative attributes
Display polygons using unique value symbols
Page 49, step 4
In the Symbology pane, click More > Symbols > Format all symbols.
The correct step text is as follows:
In the Symbology pane, click Symbols > Format all symbols.

Tutorial 2-2: Labels
Remove duplicate labels
Page 53, step 2
In the Label Class pane, click Position near the top of the pane, and then click the Conflict Resolution button.
The correct step text is as follows:
In the Label Class pane, click Position (near the top of the pane), and then click the Conflict Resolution button.

Tutorial 2-3: Definition queries
Create a definition query
Page 55, step 2
In the Layer Properties: Facilities window, click Definition Query.
The correct step text is as follows:
In the Layer Properties: Facilities window, click Definition Query > New definition query.

Page 55, step 3
Click Add Clause, Facility_T as the field, Is Equal to as the logical operator, 4901 as the value, and click Add.
The correct step text is as follows:
Click Facility_T as the Where field, is equal to as the logical operator, and 4901 as the value.
The correct image is as follows:
Page 55, step 4

Click Add Clause, Or as the logical operator, Facility_T as the field, Is Equal to 4902, and click Add.

The correct step text is as follows:

Click Add Clause, Or as the logical operator, Facility_T as the field, is equal to, and 4902.

Page 56, step 5

Repeat step 3 with Facility_T equal to 4903.

The correct image is as follows:

![Query 1](image)

First clause: Facility_T is equal to 4901
Second clause: Facility_T is equal to 4902
Third clause: Facility_T is equal to 4903

Tutorial 2-4: Choropleth maps for quantitative attributes

Create a choropleth map of households receiving food stamps

Page 61, step 2

Open the Symbology pane for this layer, and use the following guidelines to symbolize the layer.

The correct image is as follows:

![Primary symbology](image)

Fields:
- 060_FOOD
- Graduated colors
- Normalization
- Method: Quantile
- Classes: 5
- Color scheme

Classes:
- Symbol: 
  - Upper value: ≤ 830.0
  - Label: ≤830
- Symbol: 
  - Upper value: ≤ 1620.0
  - Label: ≤1620
- Symbol: 
  - Upper value: ≤ 2972.0
  - Label: ≤2972
- Symbol: 
  - Upper value: ≤ 4831.0
  - Label: ≤4831
- Symbol: 
  - Upper value: ≤ 11595.0
  - Label: ≤11595
Page 62, step 3

**Click the Histogram view button.**

The correct step text is as follows:

**Click the Histogram tab.**

The correct image is as follows:

![Histogram image]

---

**Extrude a 3D choropleth map**

Page 63, step 1

**On the View tab, in the View group, click Convert.**

Delete the current Convert button image.

The correct step text is as follows:

**On the View tab, in the View group, click Convert > To Local Scene.**

Page 63, step 4

**In the Extrusion group, for Extrusion Expression, choose [O60_Food].**

The correct image is as follows:

![Extrusion field image]
Tutorial 2-6: Normalized population map with custom scales

Create a choropleth map with normalized population and custom scale

Page 68, step 1
Symbolize Female headed households receiving food stamps using these guidelines.

The correct image is as follows:

![Graduated Colors](image)

Page 69, step 2
Click the Symbology Options button > Advanced > expand Format labels.

The correct step text and button image are as follows:

Click the Advanced Symbols Options button > expand Format labels.

Page 69, step 4
For Percentage, click “Number represents a fraction…”, and for Rounding, choose 0 for Decimal places.

The correct image is as follows:

![Advanced symbol options](image)

Page 69, step 5
Click the Back button, and click the Histogram view button.

The correct step text and button image are as follows:

Click the Primary Symbol button, and click the Histogram view button.

Page 70, step 7
Click the Label View button.

Delete the Label View button image.

The correct step text is as follows:

Click the Classes tab.
Page 70, step 9

Continue selecting break points, and enter 0.04, 0.08, 0.16, and 0.26 (the maximum value rounded to two decimal places).

The correct image is as follows:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Upper value</th>
<th>Label</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>≤ 0.02</td>
<td>≤2%</td>
</tr>
<tr>
<td></td>
<td>≤ 0.04</td>
<td>≤4%</td>
</tr>
<tr>
<td></td>
<td>≤ 0.08</td>
<td>≤8%</td>
</tr>
<tr>
<td></td>
<td>≤ 0.16</td>
<td>≤16%</td>
</tr>
<tr>
<td></td>
<td>≤ 0.26</td>
<td>≤26%</td>
</tr>
</tbody>
</table>

Page 71, step 10

Click the Histogram view button.

The correct step text is as follows:

Click the Histogram tab.

The correct image is as follows:
Import symbology and use swipe to compare features

Page 72, step 2

In the Geoprocessing pane, make the selection as shown:

The correct image is as follows:

![Image of Geoprocessing pane](image1)

Tutorial 2-7: Density maps

Create the density map

Page 74, step 1

Using the following guidelines, symbolize Food bank/soup kitchens (SQ MI).

The correct image is as follows:

![Image of density map settings](image2)
Tutorial 2-8: Group layers and layer packages

Create and add a layer package

Page 79, step 1

In the Contents pane, right-click NYC Police, and click Share as Layer Package.

The correct step text is as follows:
In the Contents pane, right-click NYC Police, and click Sharing > Share as Layer Package.

Page 80, step 2

Make selections or type as shown, saving the layer package file to Chapter2\Tutorials.

The correct image is as follows:
Chapter 3
Map outputs for GIS projects

Tutorial 3-1: Layouts

Add maps to the layout

Page 87, step 2
On the Insert tab, click the Map Frame arrow, and select the Arts Employment map to the right of Default in the first row.

The correct step text and note text are as follows:
On the Insert tab, click the Map Frame arrow, select the Arts Employment per 1,000 Population map to the right of Default in the first row, drag to draw a bounding box in the top half of the layout, and then release the mouse. This step adds the selected map displays to the layout.

Page 87, step 3
Likewise, insert the Arts Employment map from the second row.

The correct step text is as follows:
Likewise, insert the Arts Employment map from the second row into the bottom half of the layout.

Modify legends

Page 91, step 8
Click Employment per 1,000 Population, and press Delete.

The correct step text is as follows:
Click the bottom graphic of the legend, right-click, and click Ungroup. Then click Employment per 1,000 Population, and press Delete.

Page 91, step 10
In the Text box, place your cursor after Employment Arts, press Shift and Enter, and close the Format Text pane.

The correct step text is as follows:
In the Text box, place your cursor after Employment Arts, press Shift and Enter, edit the text of the second line to read per 1,000 Population, and close the Format Text pane.

Insert text

Page 94, step 1
On the Insert tab in the Text group, click the Text button.

The correct step text is as follows:
On the Insert tab in the Text group, click A Rectangle, and click Text button.
Page 94, step 5
In the Format Text pane, click text symbol > Appearance. Change the size to 16 pt, and click Apply.

The correct step text is as follows:
In the Format Text pane, click text symbol > Properties > Appearance. Change the size to 16 pt, and click Apply.

Tutorial 3-2: Visibility ranges
Open the Tutorial 3-2 project
Page 96, step 1
Open Tutorial3-2.aprx.

The correct image is as follows:

Set visibility ranges for map layers
Page 97, step 2
In the Contents pane, right-click the Employment Layer, and click Properties.

The correct step text is as follows:
In the Contents pane, right-click the Employment layer of the Arts Employment choropleth map, and click Properties.
Tutorial 3-3: Story maps
Create label fields for use online
Page 103, step 3
Create the expression as shown in the figure.
The correct image is as follows:
Share maps in ArcGIS Online

Page 105, step 7

Under My Content, for sharing options, select Everyone.

The correct image is as follows:

Move online maps to a new folder

Page 106, step 2

Go to My Content, click the New Folder button, type ArtsEmploymentStoryMapYourName for the folder name, and click Create.

The correct step text and button images are as follows:

Go to Content, and under My Content, click the Create new folder button ➕, type ArtsEmploymentStoryMapYourName for the folder name, click OK, and then click the Home button ⏐

Page 106, step 4

Click the Move button ➦ ArtsEmploymentStoryMapYourName.

The correct button image is as follows: ➦ Move
Page 106, step 5

Click the ArtsEmploymentStoryMapYourName folder.

The correct step text is as follows:

Click the ArtsEmploymentStoryMapYourName folder > Move.

Add labeling

Page 106, step 1

Open the Arts_Employment web map in the map viewer.

The correct step text is as follows:

Open the Arts_Employment_Your_Name web map in the map viewer.

Delete the note that accompanies this step. ArcGIS Online correctly uses the extent you set for layers in ArcGIS Pro.

Page 108, step 4

Select Label as Text, change the font size to 11, and click OK.

The correct image is as follows:

Page 109, YOUR TURN

Open the Cost_of_Living_Index map.

The correct text is as follows:

Open the Cost_of_Living_Index_Your_Name map.
Configure pop-ups

Page 109, step 1

Open the Arts_Employment web map in the map viewer.

The correct step text is as follows:

Open the Arts_Employment_Your_Name web map in the map viewer.

Page 109, YOUR TURN

Configure pop-ups for the Cost_of_Living map.

The correct text is as follows:

Configure pop-ups for the Cost_of_Living_Index_Your_Name map.

Create a story map

Page 109, step 2

Scroll to Presenting a Series of Maps, and for the Story Map Series side accordion layout, click the Build button.

The correct step text is as follows:

Scroll to Presenting A Series of Maps and Other Content, click Build, sign in with your ArcGIS credentials, click Continue to Map Series Builder, select Side Accordion, and click Start.

Page 110, step 5

With My Content selected, select Arts Employment, and then select the Legend check box > Add.

The correct step text is as follows:

With My Content selected, select Arts_Employment_Your_Name, and then select the Legend check box > Add.

Page 111, YOUR TURN

Click the Add button (lower-left corner of window), add the Cost_of_Living_Index_Your_Name map with the title Cost of Living Index.

The correct text is as follows:

Click the Add button (lower-left corner of window), and add the Cost_of_Living_Index_Your_Name map with the title Cost of Living Index.

Copy text to map 1

Page 112, step 1

In StoryBookManuscript.docx, select all of item 3, Map 1 Arts Employment, from “Where are the jobs in the Arts Field?” up to and including “Copy and paste Table 2 from Chapter3\Tutorials\Resources\ArtsTables.xlsx”.

The correct step text is as follows:

In StoryMapManuscript.docx, select all of item 3, Map 1 Arts Employment, from “Where are the jobs in the Arts Field?” up to and including “Copy and paste Table 2 from Chapter3\Tutorials\Resources\ArtsTables.xlsx”.
Chapter 4
File geodatabases

Tutorial 4-1: Import data into a file geodatabase

Create a new ArcGIS Pro Project

Page 127, step 2
Under Create a new project, click Blank, and make or type the following selections as shown.
The correct step text is as follows:
Under New Blank Templates, click Map, and type or make the following selections as shown.

Page 127, step 3
Click OK, and close the Catalog pane.
The correct step text is as follows:
Click OK.

Page 128, step 9
On the Insert tab in the Project group, click New Map. The new map opens with the topographic
basemap showing North America.
Delete this step and the note text.

Set up a folder connection

Page 128, step 2
Expand Folders > Tutorials. Here, you will see the contents of the Tutorials folder except for the
project files (such as Tutorial4-1.prx). When you need to add data in the future, you can click the
Tutorials folder and have direct access to its Chapter4.gdb file geodatabase instead of having to
browse along the path C:\EsriPress\GIST1\Chapter4.
The correct note text is as follows:
Here, you will see the contents of the Tutorials folder except for the project files (such as
Tutorial4-1.aprx). When you need to add data in the future, you can click the Tutorials folder
and have direct access to its Chapter4.gdb file geodatabase instead of having to browse
along the path C:\EsriPress\GIST1\Chapter4.

Page 129, step 5
In the Catalog pane, expand the Chapter4 folder. Here, you will see that Chapter4 has three subfolders:
Tutorials, Assignments, and Data.
The correct note text is as follows:
Here, you will see that Chapter4 has two subfolders: Tutorials and Data.
Import shapefiles and a data table into a file geodatabase

Page 129, step 3

In the Input Features window under Project, click Folders, double-click the Chapter4 connection, click the Data folder, click the MaricopaCounty folder, select tl_2010_04013cousub10.shp, and click OK.

The correct step text is as follows:

In the Input Features window under Project, click Folders, double-click the Chapter4 connection, double-click the Data folder, double-click the MaricopaCounty folder, select tl_2010_04013cousub10.shp, and click OK.

Page 130, step 4

For Output Feature Class, type Cities.

The correct image is as follows:

![Feature Class to Feature Class Geoprocessing](image1)

Import a data table into a file geodatabase

Page 131, step 2

For Input Rows, browse to Chapter4\Data\MaricopaCounty, select CensusData.csv, and click OK. For Output Table type CensusData.

The correct step text is as follows:

For Input Rows, browse to Chapter4\Data\MaricopaCounty, select CensusData.csv, and click OK. For Output Name type CensusData.

The correct image is as follows:

![Table To Table Geoprocessing](image2)
Use database utilities of the Catalog pane

Page 132, step 1

Click the Project button (upper-right corner of your ArcGIS Pro window) to open the Catalog pane.

The correct step text is as follows:

Open the Catalog pane.

Tutorial 4-2: Modifying an attribute table

Get started

Page 133, step 2

Right-click Tracts, and click Zoom to layer.

The correct step text is as follows:

In the Contents pane, right-click Tracts, and click Zoom to layer.

Delete unneeded columns

Page 134, step 2

One group at a time, press and hold the Shift key, and select rows crossed out in the figure by clicking the first and then the last row in the group, and then right-click within a group, and click Delete.

The correct step text is as follows:

One group at a time, press and hold the Ctrl key, and select rows crossed out in the figure by clicking the first and then the last row in the group, and then right-click within a group, and click Delete.

Page 134, step 4

Close Fields design, and examine the Tracts table.

The correct image is as follows:

<table>
<thead>
<tr>
<th>OBJECTID</th>
<th>Shape</th>
<th>GEOMID10</th>
<th>Shape_Length</th>
<th>Shape_Area</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Polygon</td>
<td>04013422644</td>
<td>0.127403</td>
<td>0.000755</td>
</tr>
<tr>
<td>2</td>
<td>Polygon</td>
<td>04013422643</td>
<td>0.09817</td>
<td>0.000499</td>
</tr>
<tr>
<td>3</td>
<td>Polygon</td>
<td>04013422642</td>
<td>0.063555</td>
<td>0.000249</td>
</tr>
<tr>
<td>4</td>
<td>Polygon</td>
<td>04013422641</td>
<td>0.132432</td>
<td>0.000748</td>
</tr>
<tr>
<td>5</td>
<td>Polygon</td>
<td>04013815900</td>
<td>0.170811</td>
<td>0.001141</td>
</tr>
<tr>
<td>6</td>
<td>Polygon</td>
<td>04013815800</td>
<td>0.075694</td>
<td>0.000274</td>
</tr>
</tbody>
</table>
Create a new attribute table and populate it using the Calculate Field tool

**Page 136, step 9**

Close the Geoprocessing pane, and take a look at the results.

The correct image is as follows:

<table>
<thead>
<tr>
<th>OBJECTID</th>
<th>Shape</th>
<th>GEOID10</th>
<th>Shape_Length</th>
<th>Shape_Area</th>
<th>GeoID10Num</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Polygon</td>
<td>04013422644</td>
<td>0.127403</td>
<td>0.000755</td>
<td>4013422644</td>
</tr>
<tr>
<td>2</td>
<td>Polygon</td>
<td>04013422643</td>
<td>0.09817</td>
<td>0.000409</td>
<td>4013422643</td>
</tr>
<tr>
<td>3</td>
<td>Polygon</td>
<td>04013422642</td>
<td>0.063555</td>
<td>0.000249</td>
<td>4013422642</td>
</tr>
<tr>
<td>4</td>
<td>Polygon</td>
<td>04013422641</td>
<td>0.132432</td>
<td>0.000748</td>
<td>4013422641</td>
</tr>
<tr>
<td>5</td>
<td>Polygon</td>
<td>04013815900</td>
<td>0.170811</td>
<td>0.001141</td>
<td>4013815900</td>
</tr>
<tr>
<td>6</td>
<td>Polygon</td>
<td>04013815800</td>
<td>0.075694</td>
<td>0.000274</td>
<td>4013815800</td>
</tr>
</tbody>
</table>

**Page 136, step 10**

Close the Tracts table and the Geoprocessing pane.

The correct step text is as follows:

Close the Tracts table.

(The Geoprocessing pane is already closed.)

Calculate the ratio of two fields

**Page 137, step 3**

In the Geoprocessing pane, click Add Clause, and make the following selections as shown.

The correct step text is as follows:

In the Select by Attribute pane, click New expression, and make the following selections as shown.

The correct step text is as follows:

The correct image is as follows:

![Expression](image_url)

**Page 137, step 4**

Click Add, and then click Run.

The correct step text is as follows:

Click Run.
Page 138, step 7
Create the expression as seen in the figure by double-clicking fields and clicking the division operator.

The correct image is as follows:

![Image of expression creation](image-url)

Extract substring fields and concatenate string fields

Page 140, YOUR TURN

An example value for GEOID10 in the Cities attribute table is 0401390459. The first two digits are the state, the next three digits are the county, and the remaining five digits are the city. Create two new text attributes, **CityNumber** (length = 5) and **CityNameNumber** (length = 50), in the Cities attribute table. Extract the last five digits of GEOID10 in CityNumber, and then concatenate the City field and CityNumber to compute values for CityNameNumber, such as Buckeye = 90459. Put a space on both sides of the equals sign. Sorted ascending by CityNameNumber, sample values are shown next.

The correct text is as follows:

An example value for GEOID10 in the Cities attribute table is 0401390459. The first two digits are the state, the next three digits are the county, and the remaining five digits are the city. Create two new text attributes, **CityNumber** (length = 5) and **CityNameNumber** (length = 50), in the Cities attribute table. Extract the last five digits of GEOID10 in CityNumber, and then concatenate the City field and CityNumber to compute values for CityNameNumber, such as Buckeye = 90459. Put a space on both sides of the equals sign. The concatenation syntax is as follows: !NAME10! + " " + "=" + " " + !CityNumber!. Sorted ascending by CityNameNumber, sample values are shown next.
Tutorial 4-3: Joining tables

Join a data table to a feature class attribute table

Page 141, step 1
In the Contents pane, right-click Tracts, and click Joins and relates > Add Join.

The correct step text is as follows:
In the Contents pane, right-click Tracts, and click Joins and Relates > Add Join.

Page 141, step 2
In the Geoprocessing pane, make the following selections as shown (ignore the warning message).

The correct step text is as follows:
In the Geoprocessing pane, make the following selections as shown.

Export a feature class to make a join permanent

Page 142, step 2
In the Geoprocessing pane, change the Output feature class’s name from Tracts_CopyFeatures to MaricopaIncome, and click Run.

The correct step text is as follows:
In the Geoprocessing pane, change the Output feature class’s name to MaricopaIncome, and click Run.

Page 142, step 5
Open the Field design view of MaricopaIncome.

Delete this step. It is no longer needed.

Page 143, YOUR TURN

The correct image is as follows:
Tutorial 4-4: Attribute queries

Open the Tutorial 4-4 project

Page 146, step 2
Use the Pittsburgh bookmark.

The correct image is as follows:

Create a date-range selection query

Page 147, step 2
In the Geoprocessing pane, for Layer Name, select Crime Offenses, click Add Clause, and make the following selections as shown.

The correct step text is as follows:

In the Geoprocessing pane, from Input Rows select Crime Offenses, click New Expression, and make the following selections as shown.

The correct image is as follows:

Page 147, step 3
Click Add and the Verify button.

The correct step text is as follows:
Click the Verify button.
Page 147, step 4
Click Add Clause and make the following selections as shown.

The correct image is as follows:

Page 147, step 5
Click Add and the Verify button.

The correct step text is as follows:
Click the Verify button.

Reuse a saved query to create a definition query

Page 148, step 1
Right-click Crime Offenses, and click Properties > Definition query > Load expression button, and double-click qryDateRange.exp.

The correct step text is as follows:
Right-click Crime Offenses, and click Properties > Definition Query, the drop-down New definition query > Add queries from files, and double-click qryDateRange.exp.

Query a subset of crime types using OR connectors and parentheses

Page 148, step 1
Open the Definition query property sheet for Crime Offenses.

The correct step text is as follows:
Right-click Crime Offenses, and click Properties > Definition Query > Edit to open the Definition Query property sheet for Crime Offenses.

Page 149, step 2
Click Add Clause, and make the following selections as shown.

The correct image is as follows:

Page 149, step 3
Click Add.

The correct step text is as follows:
Click Add Clause.
**Page 149, step 4**

Add two more clauses for Crime equal to Vagrancy and Crime equal to Vandalism, connected by OR.

The correct image is as follows:

![Table showing conditions for Crime equal to Vagrancy and Vandalism](image)

**Page 149, step 5**

Click the SQL button.

The correct button image is as follows: ![SQL button](image)

The correct image is as follows:

```
(DateOccur >= timestamp '2015-07-01 00:00:00' And DateOccur <= timestamp '2015-07-31 00:00:00' And Crime = 'Disorderly Conduct') Or Crime = 'Vagrancy' Or Crime = 'Vandalism'
```

**Page 149, step 6**

Type parentheses as shown next.

The correct image is as follows:

```
DateOccur >= timestamp '2015-07-01 00:00:00' And DateOccur <= timestamp '2015-07-31 00:00:00' And (Crime = 'Disorderly Conduct' Or Crime = 'Vagrancy' Or Crime = 'Vandalism')
```

**Page 149, step 7**

Click OK.

The correct step text is as follows:

Click Apply and then OK.

**Page 150, step 8**

Open the Definition Query property sheet for Crime Offenses, and save the query as qryDateRangeBurglaryLeadingIndicators.

The correct step text is as follows:

Open the Definition Query property sheet for Crime Offenses, hover over the query expression, click the Save icon, and save the query as qryDateRangeBurglaryLeadingIndicators.

**Page 150, step 9**

Click the Clear Expression button, and click OK.

The correct step text is as follows:

Hover over the query expression, click Remove Query, click Yes, and click OK.
Page 150, YOUR TURN

Create a saved definition query named `qryAugustBurglaries.exp` for burglaries in August 2015. Open the attribute table to verify the results. Keep the definition query in effect (don’t clear it).

The correct text is as follows:

Create a saved definition query named `qryAugustBurglaries.exp` for burglaries in August 2015. Open the attribute table to verify the results. There should be 273 records. Keep the definition query in effect (don’t clear it).

The correct image is as follows:

![Query day-of-week range](image)

**Query day-of-week range**

Page 150, step 1

Create the Select by Attributes query (and not a definition query) as shown.

The correct image is as follows:

![Query day-of-week range](image)

Page 151, step 6

In the attribute table, click the Switch Selection button.

The correct button image is as follows:

![Query person attributes](image)

**Query person attributes**

Page 152, step 2

Add a clause for `ArrName` is not null, run it, and click the Show Selected Records button on the lower-left corner of the table.

The correct step text is as follows:

Add a clause for `ArrLName` is not null, run it, and click the Show Selected Records button on the lower-left corner of the table.
Page 153, step 7

Point to the last clause, click its Edit Clause button, type WARRINGTON for its value, and click Update.

The correct step text is as follows:

Point to the last clause, and type WARRINGTON for its value.

The correct image is as follows:

<table>
<thead>
<tr>
<th>Where</th>
<th>ArrLName</th>
<th>is not null</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>And</td>
<td>ArrSex</td>
<td>is equal to</td>
<td>M</td>
</tr>
<tr>
<td>And</td>
<td>ArrRace</td>
<td>is equal to</td>
<td>W</td>
</tr>
<tr>
<td>And</td>
<td>ArrAge</td>
<td>is greater than or equal to</td>
<td>30</td>
</tr>
<tr>
<td>And</td>
<td>ArrAge</td>
<td>is less than</td>
<td>40</td>
</tr>
<tr>
<td>And</td>
<td>ArrResid</td>
<td>contains the text</td>
<td>WARRINGTON</td>
</tr>
</tbody>
</table>

Tutorial 4-5: Data aggregation with a spatial join

Open the Tutorial 4-5 project

Page 154, step 2

Use the Pittsburgh bookmark.

The correct image is as follows:
Build a spatial join

Page 155, step 2

Type or make the following selections as shown next. In the Output Fields list, starting with Area, point to each field and click the red \text{x} remove button so that only Name (from Neighborhoods) remains.

The correct image is as follows:
Create a choropleth map using Join Count from August2015BurglariesByNeighborhood. Use five quantiles and the color scheme of your choice. When finished, save and close your project.

The correct text is as follows:

Create a choropleth map using Join_Count from August2015BurglariesByNeighborhood. Use five quantiles and the color scheme of your choice. Remove labels for the layer August2015BurglariesbyNeighboood. When finished, save and close your project.

The correct image is as follows:

**Tutorial 4-6: Central point features for polygons**

**Get started**

Page 157, step 1

Open Tutorial4-5.aprx from Chapter4\Tutorials, and save it as Tutorial4-6YourName.aprx.

The correct step text is as follows:

Open Tutorial4-6.aprx from Chapter4\Tutorials, and save it as Tutorial4-6YourName.aprx.
Create a central point feature class for polygons

Page 158, step 2

Make the following selections as shown.

The correct image is as follows:

![Geoprocessing interface](image1)

Create a new point layer

Page 159, YOUR TURN

The correct image is as follows:

![Map with point features](image2)
Tutorial 4-7: Create a new table for a one-to-many join

Make a one-to-many join

Page 161, step 2

Right-click PittsburghSeriousCrimesSummer2015, click Joins and Relates > Add Join, and make the following selections as shown.

The correct image is as follows:
Chapter 5
Spatial data

Tutorial 5-1: World map projections

Project the map on the fly to Hammer-Aitoff (world)

Page 166, step 1
In the Contents pane, right-click World Projections > Properties > Coordinate Systems. The current coordinate system is CGS WGS 1984.

The correct note text is as follows:
The current coordinate system is GCS WGS 1984.

Page 166, step 2
Under XY Coordinate Systems Available, scroll down and click to expand Projected coordinate system > World, and click Hammer-Aitoff (world).

The correct image is as follows:

![XY Coordinate Systems Available](image)

Tutorial 5-3: Projected coordinate systems

Look up a zone in the state plane coordinate system

Page 170, step 1
Start a web browser, navigate to www.ngs.noaa.gov, and click Tools > State Plane Coordinates > Find Zone.

The correct step text is as follows:
Start a web browser and navigate to the following website or PDF document to find the coordinate system of your desired location:
http://stateplane.ret3.net/

Page 170, steps 2 and 3
With By County selected, click Begin Pennsylvania, and click Submit.
Click [003]Allegheny, and click Submit (leave the option button set to NAD83).

Delete these steps—they no longer apply.
Page 170, step 4

Close your web browser.

Rename as step 2, and delete the following note text:
You can use the same website to find UTM zones that you will learn about in a later tutorial.

Use state plane coordinates

Page 171, step 1

On the Project tab, click Options > Map and Scene, expand Spatial Reference, click Use spatial reference of the first operational layer, and click OK.

The correct step text is as follows:
On the Project tab, click Options > Map and Scene, expand Spatial Reference, and click Use spatial reference of the first operational layer if it is not checked. Click OK.

The correct image is as follows:

Page 172, step 3

In the Contents pane, right-click Allegheny County State Plane > Properties > General, select Feet as the display units, and click OK.

The correct image is as follows:
Add a layer using geographic coordinates

Page 173, step 3

Move Municipalities above Tracts in the Contents pane.

The correct image is as follows:

![Map Image]

Change a map’s coordinate system to UTM

Page 175, step 1

Close the Allegheny County state plane map, and open the California UTM map.

Delete the following note text:

You can look up UTM zones using the same website that you used for state plane.
Page 175, step 5
Use the California bookmark, and hover the mouse in the center of the state.

The correct image is as follows:

Page 176, YOUR TURN
The correct image is as follows:
Tutorial 5-4: Vector data formats

Examine a shapefile

Page 177, step 1

Open a computer or File Explorer window, and navigate to Chapter5\Data\. The correct image is as follows:

<table>
<thead>
<tr>
<th>Name</th>
<th>Type</th>
<th>Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>CouncilDistricts.dbf</td>
<td>DBF File</td>
<td>4 KB</td>
</tr>
<tr>
<td>CouncilDistricts.prj</td>
<td>PRJ File</td>
<td>1 KB</td>
</tr>
<tr>
<td>CouncilDistricts.shp</td>
<td>SHP File</td>
<td>654 KB</td>
</tr>
<tr>
<td>CouncilDistricts.shx</td>
<td>SHX File</td>
<td>8 KB</td>
</tr>
</tbody>
</table>

Import a shapefile into a file geodatabase and add to a map

Page 177, step 1

Open Tutorial5-4.aprx from Chapter5\Tutorials, and save it as Tutorial5-4YourName.aprx. The project opens with a map zoomed to New York City with a PCS of NAD_1983_StatePlane_New_York_Long_Island_FIPS_3104_Feet. The correct note text is as follows:

The project opens with a map zoomed to New York City with a PCS of NAD 1983 StatePlane New York Long Isl FIPS 3104 (US Feet).

Page 178, step 4

Complete the following form as shown. The correct image is as follows:
Add x,y data

Page 179, step 5
In the Make XY Event Layer pane, check to be sure XCOORD is the X Field, YCOORD is the Y Field, and click Current Map [Vector Data Formats] as the Spatial Reference.

The correct step text is as follows:
In the XY Table to Point pane, type Libraries as the Output Feature Class in Chapter5.gdb, check to be sure XCOORD is the X Field, YCOORD is the Y Field, and click Current Map [Vector Data Formats] as the Coordinate System.

The correct image is as follows.

![Image of Geoprocessing interface showing XY Table To Point tool with input table and output feature class parameters]

Page 180, step 6
Run the tool and close it after it finishes. The libraries will appear as points in the map. This layer is temporary in the project, and the points should be exported as point features.

The correct note text is as follows:
The libraries will appear as points on the map.

Page 180, step 7
Export the Libraries_Layer as NYCLibraries to Chapter5.gdb as a permanent feature class. The library point features will automatically be added from the new location of Chapter5.gdb.

Delete this step and the note text.

Page 180, step 8
Remove the Libraries_Layer and original Libraries.dbf from the Contents pane, and save your project.

Rename as step 7, and the correct step text is as follows:
Remove Libraries.dbf from the Contents pane, and save your project.
Export to a Google KML file

Page 181, step 3

Fill in the form as shown.

The correct image is as follows:

![Image](image_url)

Tutorial 5-5: US Census map layers and data tables

Download census TIGER files

Page 182, introductory text

Delete the full introductory text as follows:

In a web browser, go to [http://www.census.gov/geo/maps-data/tiger.html](http://www.census.gov/geo/maps-data/tiger.html).
Alternatively, go to [www.census.gov](http://www.census.gov), and click Geography > Maps & Data > TIGER products. Here you will see options for downloading TIGER features, including shapefiles, geodatabases with limited demographic and economic data already joined, and KML files.

Page 182, step 1

Under the heading “Which product should I use?” click TIGER/Line Shapefiles > expand Download, and click Web interface. If you have trouble finding this site, the direct URL to this link is [http://www.census.gov/cgi-bin/geo/shapefiles/index.php](http://www.census.gov/cgi-bin/geo/shapefiles/index.php).

The correct step text and note text are as follows:

In a web browser, go to [https://www.census.gov/cgi-bin/geo/shapefiles/index.php](https://www.census.gov/cgi-bin/geo/shapefiles/index.php). There are alternative methods for downloading TIGER®/Line files such as file geodatabases. This one is a direct link to individual shapefiles.

Download census tabular data

Page 184, step 4

Select the check box on the left of S0801 (Commuting Characteristics by Sex) 2015 ACS 5-year estimates > Download button > and click OK.

The correct step text is as follows:

In the topic or table box, type S0801, press Enter, select the check box on the left of S0801 (Commuting Characteristics by Sex) 2015 ACS 5-year estimates > Download button > and click OK.

Process tabular data in Microsoft Excel

Page 185, step 6

Remove the periods from cells A1 and A2, and delete row 2.

The correct step text is as follows:

Remove the periods from cells A1 and B1, and delete row 2.
Page 185, step 8

**Rename the workbook BIKE_WORK.** Your spreadsheet should look like the one shown next.

The correct note text is as follows:

Your spreadsheet should look like the one shown next. If your values are not the same, check to make sure that you downloaded the 2015 ACS five-year estimates and deleted the correct columns.

The correct image is as follows:

![Spreadsheet Image]

Join data and create a choropleth map

Page 187, step 4

**Create a choropleth map using the field Male_Bike, the color scheme Purple (5 classes), and upper values 1.5%, 3%, 6%, 12%, and 24.7%.**

The correct step text is as follows:

Create a choropleth map using the field Male_Bike, the color scheme Purple (5 classes), and upper values 1.5%, 3%, 6%, 12%, and 31.2%.

Page 188, step 10

**Zoom to the city of Minneapolis, and turn the layers on and off to see the difference in percentage of males versus females who bicycle to work, and then save your project.** Do males or females bicycle to work in different parts of Minneapolis at a higher percentage?

The correct image is as follows:

![Map Image]
Page 189, step 10

The correct image is as follows:

![Map of Hennepin County with various land use layers]

**Tutorial 5-6: Download data from the Living Atlas**

**Add a land-use layer from the Living Atlas**

Page 191, step 4

**Click USA NLCD Land Cover 2011, and click OK.** A land-use map for Hennepin County, Minnesota, with an updated legend shows areas of land use. Examples include development (red), open water (blue), forest (green), pasture/hay (yellow), and cultivated crops (brown).

The correct step text and note text are as follows:

**Click USA NLCD Land Cover, and click OK.** Wait while the raster layer loads. A land-use map for Hennepin County, Minnesota, with an updated legend shows areas of land use. Examples include development (red), open water (blue), forest (green), pasture/hay (yellow), and cultivated crops (brown).

Delete the current image.

**Extract raster features for Hennepin County**

Page 191, step 3

**Select USA NLCD Land Cover 2011 as the Input Raster and Hennepin County as the feature mask data, and save the output raster as HennepinCountyLandUse to Chapter5.gdb.**

The correct step text is as follows:

**Select USA NLCD Land Cover as the Input Raster and Hennepin County as the feature mask data, and save the output raster as HennepinCountyLandUse to Chapter5.gdb.**
Page 192, step 5
Remove the original land-use map, and zoom to the Hennepin County land-use layer.

The correct image is as follows:

![Map of Hennepin County land-use](image)

---

Tutorial 5-7: Sources of data from government websites

Download elevation contours from USGS

Page 193, step 1

In a web browser, go to [http://viewer.nationalmap.gov/basic/](http://viewer.nationalmap.gov/basic/).

The correct step text is as follows:

In a web browser, go to [https://viewer.nationalmap.gov/basic/](https://viewer.nationalmap.gov/basic/).
Page 193, step 4
Under File Format, click Shapefile, and click Find Products.

The correct image is as follows:

Page 193, step 5
Click the Add this item to the cart > the View Cart button, and click Download.

The correct step text and note text are as follows:
Click the Add this item to the cart button, and click Download. Wait while the file downloads.

Download geospatial data from Data.gov

Page 195, introductory paragraph
Data.gov is the location of the US government’s open data, where you find many useful datasets to use in your GIS projects. It also includes links to resources such as cities and other local governments.

The correct text is as follows:
Data.gov is the location of the US government’s open data, where you find many useful datasets to use in your GIS projects. It also includes links to resources such as cities and other local governments. In this exercise, you will compare the migration of Africanized honey bees (killer bees) and national park locations. Both datasets are provided by federal agencies, but you will download national parks only. The Africanized honey bees dataset (already downloaded) is now located at the following link: https://data.globalchange.gov/dataset/usgs-spread-of-africanized-honey-bees-in-the-united-states
Page 195, step 2

In the search box, type Africanized bees.

The correct step text is as follows:

In the search box, type Parks.

Page 195, step 3

Click Spread of Africanized Honey Bees in the United States—Direct Download. This is a dataset of Africanized honey bees (killer bees) spread in the United States from the Agricultural Research Service, US Department of Agriculture (USDA). The data is saved using the Linux operating system command called “tar” and is saved as a compressed .tar.gz file.

The correct step text and note text are as follows:

Click National Parks. This is a dataset of national parks provided by the US Department of Transportation. You will compare these with a previously downloaded dataset of Africanized honey bees (killer bees) in the United States from the Agricultural Research Service, US Department of Agriculture (USDA).

Page 195, step 4

Click the download button, and save the compressed file afrbeep020_nt00218.tar.gz to Chapter5\Tutorials\Downloads\DataGov. The downloaded compressed file needs special software to extract the shapefile. The already extracted files, if needed, can be found in Downloads\DataGov\AlreadyDownloaded. The downloaded shapefile does not have a coordinate system so you will next fix this using the Define Projection tool.

Delete the note text.

The correct step text is as follows:

Click the download button beside Esri Shapefile for nps_boundary.zip, save the compressed file to Chapter5\Tutorials\Downloads\DataGov, and extract it as shapefile nps_boundary.

Page 195, step 5

Close the USGS Elevation Contours map, and open the Africanized Bees Study map.

The correct step text and note text are as follows:

Close the USGS Contours map, and open the Africanized Bees Study map. The already downloaded shapefile for Africanized bees does not have a coordinate system so you will next fix this using the Define Projection tool.

Page 195, step 8

Next to Coordinate System Unknown, click the Globe button, and select Geographic coordinate system > North America > NAD 1983.

The correct step text is as follows:

Next to Coordinate System Unknown, click the Globe button, and select Geographic coordinate system > US and territories > NAD 1983.
Create a map showing the migration of Africanized bees

Page 196, step 2

Type *No Africanized Bees Yet* for break value 0, and change its color to no color.

The correct step text is as follows:

*Type No Africanized Bees Yet for break value 0, and change its fill and outline to no color.*

Page 196, step 4

*Use the Lower 48 US States bookmark, and save your project.* You can clearly see the southern states and the spread of Africanized bees between 1994 and 2010.

The correct step text and note text are as follows:

*Add the nps_boundary shapefile, rename it National Parks, change its color to green (Parks), and remove the existing basemap and basemap reference layers. Use the Lower 48 US States bookmark, and save your project.* You can clearly see the southern states and the spread of Africanized bees between 1994 and 2010 and their location near national parks.

The correct image is as follows:

---

**Tutorial 5-8: Maps from a university web service**

**Connect to ArcGIS server map service**

Page 197, step 4

Double-click pasda, click AlleghenyCountyUrbanTreeCanopy2010, and click Select.

The correct step text is as follows:

*Double-click pasda, click AlleghenyCountyUrbanTreeCanopy2010, and click OK.*
Chapter 6
Geoprocessing

Tutorial 6-1: Dissolve features to create neighborhoods and fire divisions and battalions

Examine the dissolve field and other attributes

Page 201, step 1
Open the ManhattanBlockGroups attribute table, and sort the Name field in Ascending order.

The correct image is as follows:

<table>
<thead>
<tr>
<th>OBJECTID</th>
<th>Shape</th>
<th>STATEFP</th>
<th>COUNTYFP</th>
<th>GEOID</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>18</td>
<td>Polygon 36</td>
<td>061</td>
<td>360610013002</td>
<td>BatteryParkCity-LowerManhattan</td>
<td></td>
</tr>
<tr>
<td>21</td>
<td>Polygon 36</td>
<td>061</td>
<td>360610015011</td>
<td>BatteryParkCity-LowerManhattan</td>
<td></td>
</tr>
<tr>
<td>22</td>
<td>Polygon 36</td>
<td>061</td>
<td>360610015021</td>
<td>BatteryParkCity-LowerManhattan</td>
<td></td>
</tr>
<tr>
<td>107</td>
<td>Polygon 36</td>
<td>061</td>
<td>360610007001</td>
<td>BatteryParkCity-LowerManhattan</td>
<td></td>
</tr>
<tr>
<td>111</td>
<td>Polygon 36</td>
<td>061</td>
<td>360610009001</td>
<td>BatteryParkCity-LowerManhattan</td>
<td></td>
</tr>
<tr>
<td>114</td>
<td>Polygon 36</td>
<td>061</td>
<td>360610013001</td>
<td>BatteryParkCity-LowerManhattan</td>
<td></td>
</tr>
<tr>
<td>638</td>
<td>Polygon 36</td>
<td>061</td>
<td>360610015013</td>
<td>BatteryParkCity-LowerManhattan</td>
<td></td>
</tr>
<tr>
<td>816</td>
<td>Polygon 36</td>
<td>061</td>
<td>360610317043</td>
<td>BatteryParkCity-LowerManhattan</td>
<td></td>
</tr>
<tr>
<td>817</td>
<td>Polygon 36</td>
<td>061</td>
<td>360610317044</td>
<td>BatteryParkCity-LowerManhattan</td>
<td></td>
</tr>
</tbody>
</table>

Page 201, step 2
Scroll to the right, and examine the remaining attributes.
Delete the image—it is not needed.

Dissolve block groups to create neighborhoods

Page 203, YOUR TURN

Symbolize ManhattanFireDivisions as no color and a thick red outline and ManhattanFireBattalions as graduated colors (blue, 5 classes) and normalized using Sum_Pop2010/Sum_SQMI.

The correct text is as follows:

Symbolize ManhattanFireDivisions as no color and a thick red outline and ManhattanFireBattalions as graduated colors (blue, 5 classes) and normalized using Sum_Pop2010/Sum_SQ_MI.
Tutorial 6-2: Extract and clip features for a study area

Use Select By Attributes to create a study area

Page 205, step 2

Under Layer Name or Table View, select New York City Neighborhoods, click Add Clause and Name as the Field, is Equal to, Upper West Side, and click Add.

The correct step text is as follows:

Under Input Rows, select New York City Neighborhoods, click New Expression, and then Name as the Where field, is Equal to, Upper West Side.

The correct image is as follows:

![Image of Select Layer By Attribute dialog box]

Page 206, step 6

Label the feature using Name.

Delete this step—the neighborhood is already labeled.
Use Select By Location to create study area block groups

Page 207, step 1

On the Map tab, click the Select By Location button, and type or make the following selections as shown.

The correct image is as follows:

![Select By Location Image]

Page 207, step 3

Press the Shift key, and select the remaining block groups on the west (left) side of the neighborhood.

The correct step text is as follows:

On the Map tab, click the Select button, press the Shift key, and select the remaining block groups on the west (left) side of the neighborhood.

Clip streets

Page 208, step 1

If necessary, turn off the UpperWestSideStreetsForGeocoding and UpperWestSideBlockGroups layers.

The correct step text is as follows:

If necessary, turn off the UpperWestSideStreetsForGeocoding and UpperWestSideBlockGroups layers.
Page 208, step 3

In the Geoprocessing pane, complete the parameters as shown.

The correct image is as follows:

![Geoprocessing pane](image)

Tutorial 6-3: Merge water features

Merge features

Page 211, step 2

Use the Add Many button to add all five water layers.

The correct step text is as follows:

Add all five water layers as input datasets, and complete the parameters as follows.

The correct image is as follows:

![Geoprocessing pane](image)
Page 212, step 5

Open the attribute table for NYCWater.

The correct image is as follows:
Tutorial 6-4: Append firehouses and police stations to EMS facilities

Append features

Page 214, step 5

For Target Dataset, click EMSFacilities.

The correct image is as follows:
Page 215, step 7

Zoom to the EMS Facilities layer, open the EMSFacilities attribute table, and scroll to see the added firehouses and police stations.

The correct image is as follows:
Tutorial 6-5: Intersect features to determine streets in fire company zones

Intersect features

Page 218, step 2

In the Geoprocessing pane, make or change parameters as shown, saving the output features as ManhattanFireCompanyStreets to Chapter6.gdb.

The correct image is as follows:

![Intersect features in Geoprocessing pane](image)

Page 219, step 5

Using the Central Park bookmark, click any of the line features of ManhattanFireCompanyStreets, and scroll to the bottom of the pop-up window.

The correct step text is as follows:

Turn off all layers except ManhattanFireCompanyStreets, use the Central Park bookmark, and then zoom in a few times.

Remove the image for this step.
Page 219, add step 6

The new step text and note text are as follows:

Click the Explore button, click any of the line features of ManhattanFireCompanyStreets, and scroll to the bottom of the pop-up window. The result will be street centerlines that include data about the fire companies serving each street.

The correct image is as follows:
Summarize street length for fire companies

Page 220, step 2

Click Summarize, and type or make selections as shown.

The correct image is as follows:

![Geoprocessing window with parameters for Summary Statistics]

Page 220, step 6

Open the FireCompanyTypeStreetLength table.

The correct image is as follows:

<table>
<thead>
<tr>
<th>OBJECTID_1</th>
<th>FireBN_Co_Type</th>
<th>FREQUENCY</th>
<th>SUM_Street_Length</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1_1_L</td>
<td>139</td>
<td>35732.046198</td>
</tr>
<tr>
<td>2</td>
<td>1_10_E</td>
<td>544</td>
<td>96794.841376</td>
</tr>
<tr>
<td>3</td>
<td>1_10_L</td>
<td>315</td>
<td>74371.810622</td>
</tr>
<tr>
<td>4</td>
<td>1_15_L</td>
<td>532</td>
<td>91798.225658</td>
</tr>
<tr>
<td>5</td>
<td>1_4_E</td>
<td>188</td>
<td>35341.360738</td>
</tr>
<tr>
<td>6</td>
<td>1_6_E</td>
<td>835</td>
<td>120797.725068</td>
</tr>
</tbody>
</table>
Tutorial 6-6: Union neighborhoods and land-use features

Open the Tutorial 6-6 project

Page 221, step 2
Use the Brooklyn Zoomed bookmark.

The correct image is as follows:

Union features

Page 223, step 2
In the Geoprocessing pane, complete the following selections as shown.

The correct image is as follows:
Page 224, step 5
Click one of the new polygons, and see the values for neighborhoods and land use.

The correct step text is as follows:

Zoom in a few times, click one of the new polygons, and see the values for neighborhoods and land use.

The correct image is as follows:

Calculate acreage
Page 224, step 2
Fill out the form as shown, click Run, and close the tool when it finishes.

The correct image is as follows:
Select and summarize residential land-use areas for neighborhoods

Page 225, step 4

Fill out the form as shown, click Run, and close the tool when it finishes.

The correct image is as follows:
Tutorial 6-7: Use the Tabulate Intersection tool

Use Tabulate Intersection to apportion the population of disabled persons to fire companies

Page 230, step 2

Type or make selections as shown, saving the output features to Chapter6.gdb.

The correct image is as follows:
Page 231, YOUR TURN

The correct image is as follows:
Chapter 7
Digitizing

Tutorial 7-1: Edit polygon features

Open the Tutorial 7-1 project

Page 235, step 2

Use the Main Campus bookmark to zoom to CMU’s main campus and academic buildings.

The correct image is as follows:
Move features

Page 235, step 2

On the Edit tab, click the Move button.

The correct image is as follows:

![Building polygon](image1)

Page 235, step 3

Drag the building polygon to match the building outline in the image.

The correct image is as follows:

![Building outline](image2)

Tutorial 7-2: Create and delete polygon features

Create a new polygon feature class, and add a field

Page 243, step 2

Right-click Chapter7.gdb, and click New > Feature Class.

The correct step text and note text are as follows:

Right-click Chapter7.gdb, and click New > Feature Class. The Create Feature Class tool opens, and you have six pages of data to enter.
Page 243, step 3
For Feature Class Name, type BldgsProposed, and for Geometry Type, click Polygon.

The correct step text is as follows:
For Name, type BldgsProposed, and for Feature Class Type, click Polygon. Then click Next.

Page 243, step 4
Under Coordinate System, click Bldgs.

The correct step text is as follows:
Click “Click here” to add a new field, type BLDGNAME, select Text for Data Type, type 75 for Length, and click Next.

Page 243, step 5
Click Environments, and under Output Coordinate System, click Bldgs. NAD_1983_StatePlane_Pennsylvania_South_FIPS_3702_Feet will be selected as the coordinate system.

Delete the note text.

The correct step text is as follows:
Click NAD 1983 StatePlane Pennsylvania South FIPS 3702.

Page 243, step 6
Run the tool, and after it finishes, close the Geoprocessing and Catalog panes.

The correct step text and note text are as follows:
Click Next three times, and click Finish. The new BldgsProposed feature class has been created in the file geodatabase. The feature class is empty now. Later, as you digitize features, polygons will be added to the feature class and become visible on the map.

Page 243, step 7
Open the BldgsProposed attribute table, add a field named BLDGNAME, select Text for Data Type, and type 75 for Length.

The correct step text is as follows:
From Chapter7.gdb, drag BldgsProposed to Contents.

Page 243, step 8
Save your edits, and close the BldgsProposed table and Fields view.

The correct step text is as follows:
Close the Catalog pane.
Add a feature class, and create new polygons

Page 244, step 3
In the Create Features pane, click BldgsProposed and then the Polygon button.
The correct image is as follows:

![BldgsProposed](image1)

Page 244, step 4
On the Configure toolbar, click the Line button, and drag to draw a rectangle similar to the figure. Double-click the last vertex point to finish the polygon.
The correct button image is as follows:

![Line button](image2)

The correct step text is as follows:
On the Configure toolbar, click the Line button, and drag to draw a polygon similar to the figure. Double-click the last vertex point to finish the polygon.
The correct image is as follows:

![Polygon](image3)
Use the Hamerschlag Roberts bookmark, zoom out a few times, and draw a rectangle to the north of Roberts Engineering Hall. Use the Tepper Quad bookmark to create a new polygon using the existing parking lot or building footprint as a guide. Use the Hamburg Hall bookmark, and create a new polygon between Hamburg and Smith Halls as shown in the figure. Save your edits, and use the main campus bookmark to see the proposed developments. In the attribute table, enter building names **Cohon Addition, Scott Hall, Tepper Quad, and Hamburg Addition** so that they coincide with the names shown in the figure. Show labels using the building name and a yellow halo. Save your project.

The correct text is as follows:

Use the Hamerschlag Roberts bookmark, zoom out a few times, and draw a rectangle to the north of Roberts Engineering Hall. Use the Tepper Quad bookmark to create a new polygon using the existing parking lot or building footprint as a guide. Save your edits, and use the main campus bookmark to see the proposed developments. In the attribute table, enter building names **Cohon UC Addition, Scott Hall**, and **Tepper Quad** so that they coincide with the names shown in the figure. Show labels using the building name and a white halo. Save your project.

The correct image is as follows:
Delete polygons

Page 246, step 3
Repeat step 2 to select and then delete the other building on the right of the Integrated Innovation Institute building and the buildings on the right (east) of the 4615 Forbes (GATF) building.

The correct image is as follows:

Create a study area polygon feature

Page 246, step 3
Type StudyArea for Feature Class Name, and use Polygon for Geometry Type.

The correct step text is as follows:
Type StudyArea for Name, and select Polygon for Feature Class Type.

Page 246, step 4
For Coordinate System, click Bldgs.

The correct step text is as follows:
Click NAD 1983 StatePlane Pennsylvania South FIPS 3702 as the coordinate system.

Page 246, step 5
In Environments > Output Coordinate System, click Bldgs.

The correct step text is as follows:
Click Next three times, and click Finish.

Page 246, step 6
Run the tool, and close it and the Catalog pane after the tool finishes.

The correct step text is as follows:
From Chapter7.gdb, drag StudyArea to Contents.
Page 246, step 7
Change the symbology of the StudyArea layer to 50 percent transparency.

The correct step text is as follows:
Change the symbology of the StudyArea layer to fill color White and 50 percent transparency.

Use the Trace tool to create a polygon feature

Page 247, step 6
Double-click on Boundary Street as you near the original point at the intersection of Boundary and Forbes Streets.

The correct image is as follows:

Calculate campus acreage

Page 248, step 2
Fill out the form as follows, and select Bldgs as the Coordinate System.

The correct image is as follows:
Tutorial 7-3: Create and digitize point and line features

Create a new feature class and attributes in its table

Page 249, step 3
For Feature Class name, type BusStops, and for Geometry Type, select Point.

The correct step text is as follows:
Type BusStops for Name, select Point for Feature Class Type, and click Next.

Page 249, step 4
For Coordinate System, click Bldgs.

The correct step text is as follows:
Click Next twice.

Page 249, step 5
Click Environments, and for Output Coordinate System, click Bldgs.

The correct step text is as follows:
Click the Add Coordinate System button, click Import Coordinate System, browse to and double-click
Chapter7.gdb, click Bldgs, and click OK.

Page 249, step 6
Click Run, and close the tool when it finishes.

The correct step text is as follows:
Click Finish, and then drag BusStops from the Catalog pane to the top of the Contents pane.

Page 249, step 7
Open the BusStops attribute table, and create a field named Stop_ID, with Text for Data Type and 5 for Length.
Delete this step.

Page 250, step 8
Close the attribute table. A new point feature class is in the file geodatabase and is ready for
digitizing. You will use Stop_ID to join a crosswalk table that contains bus routes associated with
each bus stop.
Delete this step and the note text.
Page 250, YOUR TURN

Create a polyline feature class in Chapter7.gdb named Paths whose coordinate system is NAD_1983_StatePlane_Pennsylvania_South_FIPS_3702_Feet. Create a field named PathName, with Text for Data Type and 25 for Length. Close the table.

The correct text is as follows:

Create a Line feature class in Chapter7.gdb named Paths whose coordinate system is NAD 1983 StatePlane Pennsylvania South FIPS 3702 Feet. Create a field named PathName, with Text for Data Type and 25 for Length.

Digitize points

Page 250, step 4

In the Create Features pane, click CMU Bus Stops and the Point button.

The correct image is as follows:

Digitize pathways

Page 252, step 4

In the Create Features pane, click Paths and the Line button.

The correct image is as follows:
Page 252, step 5
Using the Imagery basemap as reference, click a starting point at bus stop 10, Forbes Ave Opp Morewood (Carnegie Mellon), click points along the following path as shown in the image, and double-click to end the path at the entrance of Warner Hall.

The correct step text is as follows:
Using the World Streets basemap as reference, click a starting point at bus stop 10, Forbes Ave Opp Morewood (Carnegie Mellon), click points along the following path as shown in the image, and double-click to end the path at the entrance of Warner Hall.

The correct image is as follows:

Page 252, step 7
Digitize the following path from CMU’s parking garage to Warner Hall, and type Garage to Warner Hall for the path name in the attribute table.

The correct step text is as follows:
Digitize a path from Warner Hall to the Cohon University Center, and type Warner Hall to CUC for the path name in the attribute table.

Delete the image for this step.
Page 253, step 8

Save your edits, clear the selection, and label the paths using a font size 12, bold font, and blue halo.

The correct step text is as follows:

Save your edits, clear the selection, and label the paths using a font size 12, bold font, and Basic Line placement.

The correct image is as follows:

Page 253, YOUR TURN

Digitize the paths from the bus stop and garage to the Purnell Center building, and enter path names. Close the Edit and attribute tables, and clear selections. Change the symbology of the legend to unique values, using bright red for the Warner Hall paths and bright yellow for the Purnell Center paths. Save your project.

The correct text is as follows:

Digitize the paths from the bus stop to the Purnell Center building, and enter path name **Bus to Purnell Center**. Close the Edit and attribute tables, and clear selections. Change the symbology of the legend to unique values, using red for the Warner Hall paths and blue for the Purnell Center path. Save your project.

Delete the YOUR TURN image.
Tutorial 7-4: Use cartography tools

Open the Tutorial 7-4 project

Page 254, step 2

Use the Flagstaff Hill & Panther Hollow Lake bookmark.

The correct image is as follows:

Smooth a green space polygon

Page 255, step 3

Type or make selections as shown, saving the output feature class to Chapter7.gdb.

The correct image is as follows:
Page 255, step 5

Turn off the Greenspaces layer.

The correct step text is as follows:

**Turn off the Greenspaces and Water layers, and zoom to the GreenspacesSmoothed layer.**

The correct image is as follows:

![Image](image_url)

Page 256, step 6

Use the Schenley Golf Course bookmark to see the new smoothed polygons for the golf course.

The correct step text is as follows:

**Turn the Water layer on.**
Tutorial 7-5: Transform features

Add and export a CAD drawing

Page 258, step 2

**Zoom to the HBH1-Polygon Group layer.**

The correct image is as follows:

![Image of HBH1-Polygon Group layer]

Page 259, step 7

**Remove the HBH1-Polygon Group layer.**

Delete the image for this step—it is no longer needed.

Explore attributes, and classify layers

Page 259, step 1

**Open the HBH1SpacePlan attribute table.**

The correct image is as follows:

<table>
<thead>
<tr>
<th>OBJECTID</th>
<th>Shape</th>
<th>Entity</th>
<th>Layer</th>
<th>LyrFrz</th>
<th>LyrOn</th>
<th>Color</th>
<th>Linetype</th>
<th>Elevation</th>
<th>LineWt</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Polygon</td>
<td>LWPolyline</td>
<td>HALLWAY</td>
<td>0</td>
<td>1</td>
<td>40</td>
<td>Continuous</td>
<td>0</td>
<td>25</td>
</tr>
<tr>
<td>2</td>
<td>Polygon</td>
<td>LWPolyline</td>
<td>HALLWAY</td>
<td>0</td>
<td>1</td>
<td>40</td>
<td>Continuous</td>
<td>0</td>
<td>25</td>
</tr>
<tr>
<td>3</td>
<td>Polygon</td>
<td>LWPolyline</td>
<td>OFFICE</td>
<td>0</td>
<td>1</td>
<td>5</td>
<td>Continuous</td>
<td>0</td>
<td>25</td>
</tr>
<tr>
<td>4</td>
<td>Polygon</td>
<td>LWPolyline</td>
<td>OFFICE</td>
<td>0</td>
<td>1</td>
<td>5</td>
<td>Continuous</td>
<td>0</td>
<td>25</td>
</tr>
<tr>
<td>5</td>
<td>Polygon</td>
<td>LWPolyline</td>
<td>HALLWAY</td>
<td>0</td>
<td>1</td>
<td>40</td>
<td>Continuous</td>
<td>0</td>
<td>25</td>
</tr>
<tr>
<td>6</td>
<td>Polygon</td>
<td>LWPolyline</td>
<td>OFFICE</td>
<td>0</td>
<td>1</td>
<td>5</td>
<td>Continuous</td>
<td>0</td>
<td>25</td>
</tr>
</tbody>
</table>
Page 260, step 3
In the Geoprocessing pane, use Import symbology, and click SpacePlan.lyrx from Chapter7\Data\ for Symbology Layer.

The correct step text is as follows:
In the Geoprocessing pane, use Apply Symbology from Layer, and click SpacePlan.lyrx from Chapter7\Data\ for Symbology Layer.

The correct image is as follows:

Page 260, step 6
Zoom and pan the map to see the HBH1SpacePlan and study area buildings.

The correct image is as follows:
**Transform polygons**

**Page 262, step 3**

In the Modify Features pane, click Similarity for Transformation Method, and click the Add New Links button.

The correct image is as follows:

![Modify Features pane](image1)

**Page 262, step 5**

Continue adding links as shown in the figure.

The correct image is as follows:

![Map with links](image2)
Chapter 8
Geocoding

Tutorial 8-1: ZIP Code geocoding

Open the Tutorial 8-1 project
Page 268, step 2
Use the Region bookmark.

The correct image is as follows:
Build a ZIP Code locator

Page 269, step 2

Complete the tool parameters as shown.

The correct image is as follows:

Page 269, step 4

Open the Catalog pane, expand Locators, right-click PARegionZIP_CreateAddressLoc, click Locator Properties, and click Geocoding options.

The correct step text is as follows:

Open the Catalog pane, expand Locators, right-click PARegionZIPCodePoints_CreateAddr, click Locator Properties, and click Geocoding options.

Geocode data by ZIP Code

Page 270, step 3

Right-click AttendeesPARegion.csv, and click Geocode Addresses.

The correct step text is as follows:

Search for and open the Geocode Addresses tool.
Page 270, step 4
In the Geoprocessing pane, complete the tool parameters as shown.

The correct note text is as follows:

**Important note:** Do not select ARCGIS World Geocoding Service for Address Locator unless you have permission from your instructor or employer. The organizational account you are using would be billed for using the geocoding service, and you might be billed!

The correct image is as follows:

![Geoprocessing pane](image)

Page 271, step 5
Click Run. After the tool runs, the completed pop-up window shows that only three unmatched records remain.

Delete the note text.

Page 271, step 6
In the Completed pop-up, click No for start rematch process, and close the Geoprocessing tool when the rematch process finishes.

The correct step text is as follows:

Hover over View Details, and under messages, see that there were only three unmatched records. Then close the Geoprocessing tool.

**Rematch attendee data by ZIP Code**

Page 272, step 2
In the Rematch Addresses pane, for Complete ZIP Code, type 15213, and press Tab.

The correct step text is as follows:

In the Rematch Addresses pane, for Complete ZIP Code, type 15213, and click Apply.
Symbolize using the Collect Events tool

Page 274, step 5

Zoom into the southwest corner of Pennsylvania where Pittsburgh is located.

The correct image is as follows:

---

Tutorial 8-2: Street address geocoding

Build a street locator

Page 275, step 2

Complete the tool parameters as shown in the figure.

The correct image is as follows:
Geocode attendee data by street

Page 276, step 1

Right-click AttendeesAlleghenyCounty.csv, and click Geocode Addresses.

The correct step text is as follows:
Search for and open the Geocode Addresses tool.

Page 276, step 2

Complete the tool parameters as shown.

The correct image is as follows:

![Geocode Addresses tool parameters](image)

Page 276, step 4

Click No for Start rematch process, and close the geoprocessing tool.

The correct step text is as follows:
Close the geoprocessing tool.

Edit Streets

Pages 277 and 278, steps 1–3

1. Edit the TIGER map attributes.
2. Rebuild the locator (to take into account the data revisions).
3. Proceed on a case-by-case basis with the Rematching tool to skip bad addresses, edit address data, or pick from the map.

Note that these three numbered items are not steps that you perform, but rather comprise the general workflow that you will follow.
Rematch attendee data by streets

Pages 279 and 280, steps 1–10

Replace all steps, 1–10, of this exercise with the following steps:

1. **Right-click AttendeesStreets, and click Data > Rematch Addresses.**
2. **Click the Match button to match the 1 Bayard Rd, 15213 address, which now has a perfect score of 100.**
3. **Click the Next Record button.**
4. Because the next two records (100 RUDOLPH LANE and 1005 WEIGEL GILL RD) have bad addresses, click Next twice to get to 1074 OLDGATE RD.
5. **Edit the Street or Intersection value to put a space between OLD and GATE.**
6. **Click Auto Apply, and click the Match button.**
7. The next record is for the Mary Ann St record you edited and now has a 100 score match, so click the Match button.
8. The next record is a correct match although its match score of 81.84 is below the 85 threshold for matching, so click the Match button.
9. **Click the Next Record button, edit the Street or Intersection value to place a space between 123 and FAIRFAX, press Tab, and click the Match button.**
10. **Under the Edit tab, click the Save button to save your edits and then your map.**

Tutorial 8-3: Alias tables

**Build a locator with an alias table**

Page 282, step 1

*In the Catalog pane, expand locators, right-click CBDStreets_CreateAddressLoca, and click Locator Properties.*

The correct step text is as follows:

*In the Catalog pane, expand locators, right-click CBDStreetsNoAlias, and click Locator Properties.*

Page 283, step 4

**Make the selection as shown, and click OK.**

The correct image is as follows:

![Locator Properties: CBDStreetsNoAlias](image)
Geocode the Clients.cvs using the CBDStreets_CreateAddressLoca locator to produce **ClientsAliasTable**.

The correct text is as follows:

Geocode the Clients.cvs table using the CBDStreetsNoAlias locator, now with alias table included, to produce **ClientsAliasTable**.
Tutorial 9-3: Multiple-ring service area for calibrating a gravity model

Spatially join service areas and pool tag owners

Page 303, step 3
Open the resulting Join_Pooltags table, and examine the Join_Count and Name fields to see 377 sampled pool tag holders in the travel time range of 0 to 1 minutes from all pools, 512 tag holders in the range of 1 to 2 minutes, and so on. Leave the table open.

The correct step text is as follows:
Open the resulting Join_Pooltags table, and examine the Join_Count and Name fields to see 374 sampled pool tag holders in the travel time range of 0 to 1 minutes from all pools, 514 tag holders in the range of 1 to 2 minutes, and so on. Leave the table open.

Page 306, step 7
Run the tool, and close it when it finishes.
As expected, use rate declines quickly with average time from the nearest pool: 91.7 percent of youths within a mile of the nearest pool have pool tags, but the rate drops to 54.6 percent in the 1-2 minute ring, and all the way down to 25.9 percent in the 5-7 minute ring.

The correct note text is as follows:
As expected, use rate declines quickly with average time from the nearest pool: 91.02 percent of youths within a mile of the nearest pool have pool tags, but the rate drops to 54.90 percent in the 1-2 minute ring, and all the way down to 25.96 percent in the 5-7 minute ring.

The correct image is as follows:

<table>
<thead>
<tr>
<th>Name</th>
<th>AverageTime</th>
<th>UseRate</th>
</tr>
</thead>
<tbody>
<tr>
<td>5-7</td>
<td>6</td>
<td>25.96043</td>
</tr>
<tr>
<td>3-5</td>
<td>4</td>
<td>37.0864</td>
</tr>
<tr>
<td>2-3</td>
<td>2.5</td>
<td>44.06801</td>
</tr>
<tr>
<td>1-2</td>
<td>1.5</td>
<td>54.89792</td>
</tr>
<tr>
<td>0-1</td>
<td>0.5</td>
<td>91.02305</td>
</tr>
</tbody>
</table>

Make a scatterplot

Page 306, step 2
On the Feature Layer contextual tab on the Data tab, click Create chart > Scatter Plot.

The correct step text is as follows:
On the Feature Layer contextual tab on the Data tab, click Visualize > Create Chart > Scatter Plot.
**Tutorial 9-4: Facility location**

**Configure and run the Location-Allocation model**

**Page 310, step 3**

In the Import Data group, click Import Facilities, and make the following selections as shown, and then run the tool and close it when it finishes.

The correct step text is as follows:

In the Input Data group, click Import Facilities, and make the following selections as shown, and then run the tool and close it when it finishes.

**Page 311, step 4**

Click Import Demand Points, and make the following selections as shown. Under Field Mappings Property, for Weight, select AGE_5_17 (this is the target population), and for the Cutoff_Minutes property, select the Cutoff_Minutes field.

The correct step text is as follows:

Click Import Demand Points, and make the following selections as shown. Under Field Mappings Property, for Weight, select AGE_5_17 (this is the target population), and for the Cutoff_Minutes property, select the Cutoff_Minutes field. Run the tool, and close it when it finishes.

**Tutorial 9-5: Data clustering**

Replace Tutorial 9-5 with the following.

The goal of data mining is exploration, to find hidden structure, in large and complex datasets, that has some interest or value. Data clustering, a branch of data mining, finds clusters of data points that are close to each other but distant from points of other clusters. If your data points were 2D and graphed as a scatterplot, it would be easy to draw boundaries around points and call them clusters. You’d do as well as with cluster methods. The problem is when the points lie in more than 3D space because you can’t see them anymore, and that’s where cluster methods are valuable. In this tutorial, you’ll cluster crimes using three attributes/dimensions, including the severity of crimes, plus the age and gender of arrested persons.

A limitation of clustering, however it’s done, is that there is no way of knowing the “true” clusters in real data to compare them with what an algorithm determines are clusters. You take what clustering methods provide, and if you get information or ideas from cluster patterns in your data, you can confirm them or determine their predictability using additional models or other methods. Clustering is purely an exploratory method. There are no right or wrong clusters, only more or less informative ones.
This tutorial uses k-means clustering, a simple method, available in the Multivariate Clustering tool. K-means partitions a dataset with \( n \) observations and \( p \) variables into \( k < n \) clusters. In the tutorial, you’ll use a dataset with \( n = 303 \) observations, \( p = 3 \) variables for clustering, and \( k = 5 \) clusters. K-means is a heuristic algorithm, as are all clustering methods: it’s a set of repeated steps that produces good, if not optimal, results. For this tutorial’s data, the algorithm starts with a procedure that selects five 3D observations, called “seeds,” as initial centroids for clusters. Then each observation is assigned to its nearest centroid, based on Euclidean (straight line) distance in the 3D cluster variable space. Next, a new centroid is calculated for each cluster, and then all observations are reassigned to the nearest centroid. These steps are repeated until the cluster centroids do not move appreciably. So, k-means clustering is just a common-sense method.

K-means assumes that all attributes are equally important for clustering because of its use of distance between numerical points as its basis. To meet this assumption, it’s important that all input attributes be scaled to similar magnitudes and ranges. Generally, you can use standardized variables (for each variable, subtract its mean and divide by its standard deviation) to accomplish scale parity, but other ways of rescaling are acceptable, too. It is the range, or relative distances between observations, that’s important in k-means clustering. The data used in this tutorial includes numerical (interval or ratio), ordinal, and nominal class data for classification; whereas, strictly speaking, k-means clustering is intended for numerical data because of its use of distance in cluster variable space. Nevertheless, with rescaling, it’s possible to get informative clusters when including nonnumerical data. So, next, the discussion turns to the specific case at hand and how to rescale attributes.

The data used in this tutorial is serious violent crimes from a summer in Pittsburgh, with the data mapped as points. The crimes are ranked by seriousness using FBI hierarchy numbers (1 = murder, 2 = rape, 3 = robbery, and 4 = aggravated assault), with murder being the most serious. Clearly, the nature of crimes should be important for their clustering. So, the first assumption you must make is that the “distance” between crime types, such as 3 between 1 for murder and 4 for aggravated assault (attempted or actual serious bodily harm to another person), is meaningful for clustering purposes. The criminal justice system agrees on the order, and for clustering, we can accept the “distances” or change them using our judgment. You’ll leave them as listed above.

Next, consider the single numerical attribute that is available, age of arrested person. Crime is generally committed by young adults, tapering off with older ages. For the serious violent crimes studied here, age varies between 13 and 65 (range of 42), with a mean of 29.7. Together with crime seriousness, age would dominate clustering because of its greater range. The remedy is to standardize age, so that it varies from -2.3 to 2.7 with a range of 5, whereas crime seriousness has a range of 3. Thus, both attributes have equal weight in determining clusters.
Finally, there is a nominal attribute, gender (male or female). This attribute can be encoded as a binary attribute: 0 = male, 1 = female. As a binary indicator variable, gender has a mean, which is the fraction of arrestees who are female. This variable, as encoded here, would have perhaps a lesser role than the previous two, but not by that much. If you wanted to increase the importance of the binary variable for clustering, you could encode it as a (0, 2) or (0, 4) indicator. You’ll leave it as a (0, 1) variable, which makes interpretation of clustering results easier.

One last point is that you must choose the number of clusters instead of having k-means clustering find an optimal number. That’s the case for most clustering methods. For the crime data, experimentation with three through six clusters resulted in five clusters being the most informative, so you’ll run with five clusters.

In summary, each observation is a 3D vector (crime, standardized age, gender); for example, (1, −0.364, 0) is a murder with an arrested 25-year-old (standardized age 25 is −0.364) male. The clusters found by k-means exist in the 3D space in which the observations lie. Each cluster is characterized by its centroid with the corresponding mean of each cluster variable.

Open a map project

1. Open Tutorial9-5.aprx from Chapter3\Tutorials, and save it as Tutorial9-5YourName.aprx.
2. Use the Pittsburgh bookmark.

The map shows the spatial distribution of serious violent crimes by crime type within police zones. Each zone has a commander, station, officers, and staff. Also shown are the poverty areas from chapter 1. Generally there is a positive correlation between poverty and crime. Police do not record any measures of poverty for arrested persons, such as annual income, so you cannot readily include poverty as a clustering variable. So, the map adds poverty as an additional variable for interpretation of clustering results.
3. Open the attribute table for Serious Violent Crimes, and scroll to the last column, Seed, which has been used to sort the data in descending order.

The five records with a Seed value of 1, found in a previous run of the Multivariate Clustering algorithm, are used as initial cluster centroids. The Hierarchy attribute is the FBI code for crime types and is one of the three cluster attributes. ArrAge is the age of the arrested person and is the second cluster variable. Multivariate clustering automatically standardizes numerical variables, so ArrAgeStnd, which is ArrAge standardized, is not needed. The (0,1) attribute, ArrGender, is the remaining cluster variable. Notice that there is a good deal of variation in the cluster variables of the seed records.

<table>
<thead>
<tr>
<th>Crime</th>
<th>ArrAge</th>
<th>DateOccur</th>
<th>DayOfWeek</th>
<th>ArrAgeStnd</th>
<th>ArrGender</th>
<th>Seed</th>
</tr>
</thead>
<tbody>
<tr>
<td>Robbery</td>
<td>14</td>
<td>6/1/2015</td>
<td>Monday</td>
<td>-1.299793</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>Murder-Manslaughter</td>
<td>57</td>
<td>6/12/2015</td>
<td>Friday</td>
<td>2.226864</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>Robbery</td>
<td>39</td>
<td>6/19/2015</td>
<td>Friday</td>
<td>0.750589</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>Aggravated Assault</td>
<td>47</td>
<td>7/22/2015</td>
<td>Wednesday</td>
<td>1.406711</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>Aggravated Assault</td>
<td>14</td>
<td>8/9/2015</td>
<td>Sunday</td>
<td>-1.299793</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>Aggravated Assault</td>
<td>39</td>
<td>6/1/2015</td>
<td>Monday</td>
<td>0.750589</td>
<td>1</td>
<td>0</td>
</tr>
</tbody>
</table>

4. Close the table.
Run the clustering algorithm

The k-means algorithm is in a geoprocessing tool called Multivariate Clustering, which you’ll run next.

1. **Open the Multivariate Clustering tool.**
2. **Carefully fill out everything on the tool form as follows. Use the Tab key to move to a new field and not the Enter key because doing so may run the tool prematurely.**

   Note that if you ran this tool for your own data or in an assignment, you’d use the Optimized seed locations instead of User-defined seed locations for Initialization Method.

![Multivariate Clustering tool form](image)

3. **Double-check the form, and then run the tool.**

   When finished, ArcGIS® Pro adds the SeriousViolentCrimes_Clusters layer, which has the five identified clusters, to the Contents pane. The warning message says that the tool was not able to read 38 of the 303 crime records, but those are only records that did not geocode successfully in a data preparation step. Those 38 records are in the attribute table but not on the map, and they are not a problem in terms of successfully computing clusters for the 265 geocoded records.

4. **Close the Geoprocessing window.**
5. In the Contents pane, turn off Serious Violent Crimes.

YOUR TURN
As an aid in analyzing the resulting clusters, next run the Summary Statistics tool and calculate the means for clustered variables by cluster as seen in the following graphic.
Interpret clusters

The following table has the rows and values of the summary statistics table to which labels have been added for ranges of cluster variable means.

<table>
<thead>
<tr>
<th>ClusterID</th>
<th>Frequency</th>
<th>Crime</th>
<th>Age</th>
<th>Gender</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>75</td>
<td>2.6</td>
<td>23</td>
<td>0</td>
</tr>
<tr>
<td>Young males moderate</td>
<td></td>
<td>moderate</td>
<td>young</td>
<td>male</td>
</tr>
<tr>
<td>2</td>
<td>2</td>
<td>1.0</td>
<td>51</td>
<td>1</td>
</tr>
<tr>
<td>Middle-aged females highest</td>
<td></td>
<td>highest</td>
<td>middle age</td>
<td>female</td>
</tr>
<tr>
<td>3</td>
<td>63</td>
<td>3.6</td>
<td>46</td>
<td>0</td>
</tr>
<tr>
<td>Middle-aged males lowest</td>
<td></td>
<td>low</td>
<td>middle age</td>
<td>male</td>
</tr>
<tr>
<td>4</td>
<td>70</td>
<td>4.0</td>
<td>24</td>
<td>0</td>
</tr>
<tr>
<td>Young males lowest</td>
<td></td>
<td>lowest</td>
<td>young</td>
<td>male</td>
</tr>
<tr>
<td>5</td>
<td>55</td>
<td>3.8</td>
<td>29</td>
<td>1</td>
</tr>
<tr>
<td>Young females lowest</td>
<td></td>
<td>lowest</td>
<td>young</td>
<td>female</td>
</tr>
</tbody>
</table>

These results have moderately interesting patterns and one anomalous group, 2. With a group size of only two crimes for group 2, we can’t rely on the result that women in their early 50s or thereabouts are especially dangerous murderers. That’s not a pattern likely to be repeated. Group 1 is young males committing a range of serious violent crimes. Group 3 is middle-aged criminals committing crimes toward the lesser end of serious violent crimes, mostly aggravated assaults (FBI hierarchy 4). Group 4, young males, is committing aggravated assaults. Finally, group 5, young females, mostly commits aggravated assaults. Next, you can see if there are any spatial patterns for these groups.
1. Open Symbology for SeriousViolentCrimes_Clusters, and relabel the groups as follows:
   1. Young males middle
   2. Middle-aged females highest
   3. Middle-aged males lowest
   4. Young males lowest
   5. Young females lowest

2. Keep the same colors, but change the point symbols for the three young groups to Square 1, size 5.

The cluster results that were judged moderately interesting earlier get more interesting when mapped. The serious violent crimes in Pittsburgh's central business district (arrow in middle of map) are predominantly by middle-aged criminals. Crime patterns in central business districts of cities are often unique, in part because most persons present in those districts travel to them from their residences over some distance. Youths tend to commit crimes near where they live whereas older criminals, who have higher mobility, travel to the central business district to commit crimes. Most crimes in poverty areas are by young persons, and we know from the distance-to-crime theory of criminology that these persons tend to commit crimes near where they live, within a mile or so. Somewhat surprising is the high percentage, 21 percent, of the serious violent crimes in the data that were aggravated assaults committed by females. Those crimes are highly scattered across Pittsburgh, except the southwest police zone which shows only one such crime. Of interest in that zone is the group of serious violent crimes committed by youths in an area not considered to be a poverty area (indicated by the lower-left arrow).

3. Save your project.
Chapter 10
Raster GIS

Tutorial 10-1: Process raster datasets
Symbolize a raster dataset using a layer file

Page 328, step 1
Open LandUse_Pittsburgh’s Symbology pane, and click the Menu button ➔ Import symbology.
The correct step text is as follows:
In Contents, move LandUse_Pittsburgh above NED_Pittsburgh, open LandUse_Pittsburgh’s Symbology pane, and click the Options button ➔ Import....

Page 328, step 2
Browse to Chapter10\Data, double-click LandUse.lyr, and turn off NED_Pittsburgh.
The correct step text is as follows:
Browse to Chapter10\Data, double-click LandUse.lyr, and close the Symbology pane.

Page 328, step 3
In the Contents pane, expand LandUse_Pgh to see land-use categories and their colors.
Delete this step.

Symbolize hillshade

Page 330, step 2
Type or make the following selections as shown.
The correct step text is as follows:
Type or make the following selections as shown. After you click the Color scheme arrow, click the Show all check box, and then select the black-to-white color scheme.

Create elevation contours

Page 332, step 4
Turn off LandUse_Pittsburgh and Hillshade_Pittsburgh.
The correct step text is as follows:
Turn off LandUse_Pittsburgh, Hillshade_Pittsburgh, and NED_Pittsburgh.
Tutorial 10-2: Make a kernel density (heat) map

Estimate the number of annual heart attacks using threshold areas

Page 339, step 6

Open the SummarizeAreas attribute table, and sort it by Sum Total descending.

The correct step text is as follows:

Open the SummarizedAreas attribute table, and sort it by Sum Total Descending.

Tutorial 10-3: Build a risk index model

Add processes to the model

Page 346, step 6

Search for the Raster Calculator tool, drag it to the right of your other model components, and close the Geoprocessing pane.

The correct step text is as follows:

Search for the Raster Calculator (Spatial Analyst Tools) tool, drag it to the right of your other model components, and close the Geoprocessing pane.

Configure a kernel density process

Page 347, step 2

Right-click Kernel Density, and rename it FHH Kernel Density.

The correct step text is as follows:

Right-click Kernel Density, rename it FHH Kernel Density, and click OK.

Symbolize a KDS raster layer, and save its layer file

Page 352, step 4

Right-click PovertyIndex, click Save as layer file, and save as PovertyIndex to Chapter10\Tutorials.

The correct step text is as follows:

Right-click PovertyIndex, click Sharing > Save As Layer File, and save as PovertyIndex to Chapter10\Tutorials.

Add variables to the model

Page 353, step 1

Open your model.

The correct step text is as follows:

Using Catalog, edit your model.
Use a layer file to automatically symbolize the raster layer when created

Page 355, step 4

In that cell, click the resulting browse button, navigate to Chapter10\Tutorials, and double-click PovertyIndex.lyrx.

The correct step text is as follows:

In that cell, click the resulting browse button, navigate to Chapter10, and double-click PovertyIndex.lyrx.
Chapter 11
3D GIS

Tutorial 11-1: Explore a global scene

Explore a scene’s properties

Page 359, step 1
In the Contents pane, right-click 3D Scene > Properties.
The correct step text is as follows:
In the Contents pane, right-click WorldElevation3D/Terrain3D Surface > Properties.

Page 359, step 2
In the Map Properties: 3D Scene window, click Elevation Surface, and expand Elevation sources.
The correct step text is as follows:
In the Elevation Source Properties window, click Source.
The correct image is as follows.

Page 359, step 3
Click General, and under Elevation Units, click Feet, and then click OK.
The correct step text is as follows:
Under Vertical Units, click Feet, and then click OK.

Change the basemap

Page 361, step 1
Use the Football Stadium bookmark.
The correct step text is as follows:
Use the Football Stadium bookmark, and zoom out a few times if necessary to see the Heinz Field football stadium along the river.

Page 361, step 3
Use the Baseball Stadium bookmark and the mouse or keyboard to see additional views.
The correct step text is as follows:
Use the Baseball Stadium bookmark, zoom out, and use the mouse or keyboard to see additional views.
Page 361, step 4

Change the basemap back to Topographic.

The correct step text is as follows:

Change the basemap back to Topographic, and use the Rivers bookmark.

Exaggerate and apply a shade and time to a surface

Page 361, step 1

Use the Rivers bookmark, open the 3D scene’s properties, and click Elevation Surface.

The correct step text is as follows:

In the Contents pane, under Elevation Surfaces, click Ground, and the Appearance tab.

Page 361, step 2

For Exaggeration, type 1.5, and turn on Shade surface relative to the scene’s light position.

The correct step text is as follows:

For Vertical Exaggeration, type 3.00, and turn on Shade Relative to Light Position.

Page 361, step 3

Click Illumination, click Date and time, and click OK.

The correct step text is as follows:

In the Contents pane, right-click 3D Scene > Properties > Illumination, click Date and time, and click OK.

Tutorial 11-2: Create a local scene and TIN surface

Set a local scene

Page 362, step 3

Click Custom extent, and for Calculate from, click Contours.

The correct step text is as follows:

Click Use a custom extent, and for Get extent from, click Contours.

Page 363, step 4

Turn Clip layers to extent on, and click OK.

The correct step text is as follows:

Click Clip Layers > Clip to a custom extent, click Contours, and click OK.

Delete the image for this step.
In the Contents pane, turn off Contours and Light Gray Canvas basemap, and expand PGH_TIN.
The TIN elevation is displayed with elevation heights from high to low.

The correct step text and note text are as follows:
In the Contents pane, turn off Contours and the basemap, and expand PGH_TIN.
The TIN elevation is displayed with elevation heights from high to low.

Change the scene’s surface and coordinate system

Page 365, step 1
In the Contents pane, right-click TIN Surface Scene > Properties > Elevation Surface > Elevation sources.
The correct step text is as follows:
In the Contents pane, under Elevation Surfaces, right-click Ground > Add Elevation Source, navigate to Chapter11\Tutorials, click PGH_TIN, and click OK.

Page 365, step 2
Click the red X beside elevation source WorldElevation3D/Terrain3D.
The correct step text is as follows:
In the Contents pane, under Elevation Surfaces, remove WorldElevation3D/Terrain3D.

Page 365, step 3
Click Coordinate Systems.
Delete this step. It is not needed.

Page 365, step 4
Click OK, and remove World Light Gray Canvas Base from the Contents pane.
The correct step text is as follows:
Remove World Light Gray Canvas Base from the Contents pane.
Rename step 4 as step 3.
Tutorial 11-3: Create Z-enabled features

Use 3D symbols with real-world coordinates

Page 370, step 3

Scroll to 3D Vegetation - Realistic, and click Norway Maple.

The correct step text is as follows:

Scroll to 3D Vegetation - Thematic, and click Norway Maple.

The correct image is as follows:

![3D Vegetation - Realistic](image)

Page 370, step 6

In the Contents pane, right-click 3D Trees Scene > Properties > Illumination, turn on Display shadows in 3D, and click OK.

The correct step text is as follows:

In the Contents pane, right-click 3D Trees Scene > Properties > Illumination, make sure Display shadows in 3D is checked, and click OK.
Page 370, step 8

**Zoom in and out.**

Your scene is now populated with realistic-looking trees at a consistent height.

The correct note text is as follows:

Your scene is now populated with thematic trees at a consistent height.

The correct image is as follows:

---

**Add realistic preset trees using a table of a tree’s genus (type)**

Page 371, step 4

**Use the Street Trees bookmark.**

The correct image is as follows:
Tutorial 11-4: Create features and line-of-sight analysis using lidar data

Create an LAS dataset

The correct subheading title is as follows:

Create a LAS dataset

Page 373, step 3

Type or make the following changes as shown.

The correct image is as follows:
Page 374, step 4

Run the tool, and close it after it finishes.

The correct image is as follows:

---

**Generate a raster DSM (digital surface model)**

Page 374, step 1

In the Contents pane, right-click Chapter11_LasDataset.lasd > LAS Filters > 1st Points.

The correct step text is as follows:

In the Contents pane, right-click Chapter11_LasDataset.lasd > LAS Filters > 1st Return.

Page 374, step 2

On the Appearance tab, click the Tools button, and search for and open the LAS Dataset To Raster tool.

The correct step text is as follows:

On the Analysis tab, click the Tools button, and search for and open the LAS Dataset To Raster tool.
Generate a raster DTM (digital terrain model)

Page 376, step 2

Turn the Chapter11_LasDataset.lasd layer on, and in the Contents pane, right-click Chapter11_LasDataset.lasd > LAS Filters > Ground.

The correct image is as follows:

Page 377, step 4

Run the tool, and close it after it finishes.

The correct step text is as follows:

Run the tool, close it after it finishes, and ignore any warning messages.

Join the maximum z-value (height) to building footprints, and display as 3D buildings

Page 380, step 5

On the Appearance tab in the Extrusion group, under Type, click Max Height and [BldgHeights.MAX_Z] as the field.

The correct step text is as follows:

On the Appearance tab in the Extrusion group, under Type, click Max Height and [MAX_Z] as the field.
Use lidar to determine bridge elevation heights

Page 381, step 2

On the Map tab, click the Explore button, and click on various lidar points along the bridge to see the z-values (height).

The correct image is as follows:

---

Draw a bridge using a Z elevation

Page 382, step 1

On the View tab, click Convert.

The correct step text is as follows:

On the View tab, click Convert > To Map, and turn the Bridges layer on

Page 382, step 3

Zoom to the bridge as seen in the figure, click the Create button > Bridges layer, and click to digitize the approximate location of the bridge.

The correct image is as follows:
Page 382, step 5
Click the Create button > Bridges layer, and click to digitize the bridge span as seen in the figure. Pan and zoom as necessary.

The correct step text is as follows:
Click the Create button > Bridges layer, and click to digitize a bridge span polygon as seen in the figure. Pan and zoom as necessary.

The correct image is as follows:

Page 384, step 6
Turn the Chapter11_LasDataset layer off to see the features that are visible (green) and not visible (red) between the observer points.

The correct step text is as follows:
Turn the Chapter11_LasDataset layer off and turn off Z-mode to see the features that are visible (green) and not visible (red) between the observer points. Save your project.

Tutorial 11-5: Work with 3D features

Use a range slider to view building floors

Page 388, step 8
On the Range tab in the Active Range group, click <None> for value.

The correct step text is as follows:
On the Range tab in the Active Range group, click <None> for the Name value.
Edit a building’s height using dynamic constraints and the attribute table

Page 388, step 2
On the Edit tab, click the Z Mode button to turn it off.

The correct step text is as follows:
Click the Modify button, and in the Modify Features pane under Alignment, click Scale.

Page 388, step 3
Click the Modify button, and in the Modify Features pane under Alignment, click Scale, and then click the large tower on Grant Street.

The correct step text and note text are as follows:
Click the large tower on Grant Street.
The dynamic constraint icon will appear on the tower polygon. If your icon does not appear, you can turn on “Show dynamic constraints in the map” by clicking Project, then Options, and then Editing. You can adjust the map if necessary to better see the tower and constraint icon.

Page 389, step 4
Click the green (Z) constraint to scale the tower in the Z direction to the height of the rectangular part of the tower. If you have lidar data, snap to those points.

The correct step text and note text are as follows:
Click the green (Z) constraint to scale the tower in the Z direction to the height of the rectangular part of the tower.
If you had lidar data, you could snap to those points to determine the building height.

Page 389, step 5
Click to finish the tower.

The correct image is as follows:
Tutorial 11-6: Use procedural rules and multipatch models

Page 391, step 7
   Add the following step:
   In the Contents pane, right-click USSteelBldg > Properties > Elevation, and under Features are, click On the ground, and then click OK.

View multipatch models of buildings and street furniture

Page 394, step 3
   Turn on Smithfield Furniture, and wait for the view to render.
   The correct step text is as follows:
   Turn on Smithfield Furniture, change the basemap to Dark Gray Canvas, and wait for the view to render.
Chapter 12
Operations management with GIS: Graffiti Mapping System

Tutorial 12-1: Create tasks for the Graffiti Mapping System

Page 405, Open the Tutorial 12-1 project

Replace Tutorial 12-1, on pages 405–10, with the following.

Open an ArcGIS Pro project

1. Open Tutorial12-1 from Chapter12\Tutorials and save it as Tutorial12-1YourName.
2. Use the Pittsburgh bookmark.

You’ll build a ModelBuilder model in this exercise for creating and symbolizing a Graffiti feature class from XY event data. When you create a new Graffiti feature class, it will replace the starting Graffiti feature class and symbolize it using unique values for types of graffiti. The starting Graffiti layer in the map is symbolized with a single symbol so that you can see that the model creates a new Graffiti feature class and changes symbology to unique values.

Build the Graffiti Data Import model

When you build a model, you search for geoprocessing tools and add them to the model. Once you connect data to the tools and set tool parameters, you’ll have model processes. The model you’ll build in this exercise, as seen in the next figure, has three processes:

- The first process imports the raw XY graffiti data, which has geographic latitude/longitude coordinates, into a feature class with the same coordinates.
- The second process projects the feature class from geographic coordinates to Web Mercator coordinates that are preferred for ArcGIS Online.
- The third process symbolizes the map layer with unique symbols for type of graffiti.
1. On the Analysis tab, in the Geoprocessing group, click the ModelBuilder button.
2. On the Analysis tab, in the Geoprocessing group, click the Tools button, and in the Geoprocessing pane, search for (but do not open) the XY Table to Point tool.
3. Drag the XY Table to Point tool to the Model window.
4. Similarly search for and add the Project and Apply Symbology From Layer tools to the Model window in order, as seen in the next graphic, and when finished close the Geoprocessing pane.

Configure the XY Table To Point process

1. In your model, double-click the XY Table To Point tool element.
2. In the window that opens, for Input Table, browse to Chapter12\Data and double-click Graffiti20160603.txt. Graffiti20160603.txt is the raw CSV data from a 311 system. ArcGIS Pro automatically identifies and adds the X and Y fields, X and Y, as well as the correct spatial reference of GCS_WGS_1984 (geographic, latitude and longitude). Note that Spatial Reference is for the current coordinates of the XY data.
3. **Rename Output Feature Class as GraffitiGeo.**

![Image of XY Table To Point dialog box]

4. **Click OK.**
   The process and its input and output diagram elements now have color fill, indicating that the process is configured, valid, and ready to use.

5. **Right-click the input Graffiti20160603.txt ellipse, click Rename, replace the existing name by typing Input XY Data, and press Enter.**
6. **Right-click the input again, and click Parameter.**
   Making any input or output a parameter allows you to search for the input data or name and locate the output when you run the model.

---

**Configure the Project process**

1. **Double-click the Project process.**
2. **Make selections or type as shown in the following figure, starting with selecting GraffitiGeo for Input Dataset or Feature Class and according to the following notes for coordinate systems.**
   - Leave Input Coordinate System and Geographic Transformation blank.
   - For Output Coordinate System, click the Select coordinate system button, expand the Coordinate System tree to Projected coordinate system > World > WGS 1984 World Mercator (auxiliary sphere).
3. Ignore the warning, and click OK.

Configure the Apply Symbology From Layer process

1. In the model, drag the output of the Project process, Graffiti, to the Apply Symbology From Layer process, and select Input Layer.
2. Double-click the Apply Symbology From Layer process, and for the Symbology Layer browse to Chapter 12\ Tutorials\Resources, select Graffiti.lyrx, make additional selections if necessary, and click OK.
3. **Right-click the output of this process, Graffiti_Layer, and click Parameter.**
   This action adds the Graffiti layer to the map display when the model is run from its user interface. You will use the interface near the end of this tutorial.

4. **Save and close your model.**

**Rename and run the model**

1. **Open the Catalog pane, expand Toolboxes > Tutorial12.tbx, and rename Model as Graffiti Data Import.**
2. **In the Contents pane, right-click Graffiti Data Import, and click Edit.**
   The model opens in edit mode.
3. **Hide or close the Catalog pane.**
4. **On the ModelBuilder tab in the Run group, click Run, and after the model runs, close the window with processing information.**

   After the model runs, the old Graffiti layer is replaced by the newly imported and projected Graffiti layer, and the new layer is symbolized with unique symbols by graffiti type. Also, the process elements in the model get drop shadows, indicating that they have been run. If you need to run the model again in edit mode, you must click the Validate button in the ModelBuilder Run group, which removes the drop shadows. If you are diagnosing a model, you can run it step by step by right-clicking each process and clicking Run.

5. **Close the Model window that has processing information.**

   If there were any errors, they would be in red font in the processing window and include diagnostic information.

6. **Right-click the output of the Apply Symbology From Layer process, Graffiti_Layer, click Add To Display, and then look at the Graffiti map to see that it has new data and symbolization.**

7. **Save and close the Graffiti Data Import model.**
8. **On the Analysis tab, click Tools, search for Graffiti Data Import, and click Open.**
In this model interface, the user can browse for the needed graffiti XY data. Note that by naming the input file with the date in YYYYMMDD format, such as Graffiti20160603, the files are sorted chronologically, making it easy to find the latest file.

![Geoprocessing interface with Graffiti Data Import tool](image)

9. **Click Run, and when the model finishes, close the Geoprocessing pane.**
The model runs like any other geoprocessing tool.

10. **Save your project.**

### Tutorial 12-2: Create tasks to import graffiti data

#### Create a new task item for preparing graffiti data

**Page 411, step 1**

**On the Insert tab in the Project group, click the Task button ![Task button](insert_icon), and then click New Task Item.**
The Tasks and Task Designer panes open. You create new task items, tasks, and steps in Tasks and configure them in Task Designer.

The correct note text is as follows:
The Tasks and Task Designer panes open. Notice that the Tasks pane is tabbed at the bottom left with the Contents pane. You create new task items, tasks, and steps in Tasks and configure them in Task Designer.

**Page 411, step 3**

**Type the following information as shown into the text boxes on the Task Designer pane for the task item. Type your name for author.**
Create the Prepare Data task

Page 412, step 2

In the Task Designer pane for Name, type a. Prepare Data and for Description, type Has steps: 1. Enter Date 2. Save Edits 3. Create Graffiti Feature Class.

The correct image is as follows:
Create the Enter Date step

Page 412, step 3

*For the step instructions, type*

i. Enter a new date to replace the old date in the Heading field in the Heading attribute table. ii. Press Enter to update the Attribute field. Ensure that you press Enter after each instruction as needed to place the start of the next instruction on a new line.

The correct step text is as follows:

*For the step instructions, type*

i. Enter a new date to replace the old date in the Heading field in the Heading attribute table. ii. Press Enter to update the Attribute field. iii. Click Next. Ensure that you press Enter after each instruction as needed to place the start of the next instruction on a new line.

Page 413, step 5

*In the Task Designer pane, in the top horizontal menu, click Actions, point to the command bar, and click the Record button as shown in the figure.*

The correct image is as follows:

Page 413, step 9

*In Task Designer, click the Views tab, and ensure that Graffiti Map is active and open.*

The correct image is as follows:
Page 414, step 10

In Task Designer, click the Contents tab, and turn on layer selection for the Heading layer (click once) and turn off the other layers (click twice).

The correct image is as follows:

---

Create the Add Graffiti XY Event Data step

Page 415, step 5

Click the Actions tab, point to the command bar, and click the Edit button.

The correct image is as follows:
Page 415, step 6

For Type of Command, select Geoprocessing Tool, search for and select Graffiti Data Import, and click OK.

The correct image is as follows:

![Task Designer screen](image)

Page 416, Your Turn

Repeat all the steps of the Prepare Data task. ... Edit the date to be June 3, 2016, which you will need for further work in this chapter, and save the edits. The Add Graffiti XY Event Data step runs automatically, resulting in a new Graffiti feature class in the Contents pane. Click Finish.

The correct Your Turn text is as follows:

Repeat all the steps of the Prepare Data task. ... Edit the date to be June 10, 2016, and save the edits. The Add Graffiti XY Event Data step runs automatically, resulting in a new Graffiti feature class in the Contents pane. Click Finish.

Share the Graffiti and Heading web layers

Page 416, step 2

In the Contents pane, right-click Graffiti, and click Share As Web Layer.
The correct step text is as follows:

In the Contents pane, right-click Graffiti_Layer, and click Sharing > Share As Web Layer.

**Page 417, Create the Share Heading Web Layer step**

The correct exercise title follows:

**Create the Share Heading and Graffiti Web Layers steps**

**Page 417, step 2**

*In Task Designer, for Name, type Share Heading Web Layer. For Instructions, type* i. In the Contents pane, right-click Heading Your Name, and click Overwrite Web Layer. ii. Click My Content, select Heading Your Name, and click OK. iii. In the warning window, click OK. iv. Click Publish. v. When publishing finishes, close the Overwrite web layer window. *For Step behavior, select Auto Run.*

*The correct step text is as follows:*

In Task Designer, for Name, type Share Heading Web Layer. For Instructions, type i. In the Contents pane, right-click Heading, and click Sharing > Overwrite Web Layer. ii. Click My Content, select Heading Your Name, and click OK. iii. In the warning window, click OK. iv. Click Publish. v. When publishing finishes, close the Overwrite web layer window. *For Step behavior, select Auto Run.*

**Page 417, step 4**

*Add a new step to the Share Web Layers task using steps 1 and 2 and replacing Heading Your Name with Graffiti Your Name.*

*The correct step text is as follows:*

Add a new step to the Share Web Layers task using steps 1 and 2 and, in step 2, replacing the first occurrence of Heading with Graffiti_Layer and the second occurrence of Heading with Graffiti.

**Page 417, Your Turn**

Repeat both tasks, Prepare Data and Publish Web Layers ... reenter **June 3, 2016**. When you finish, save your project, and close ArcGIS Pro.

*The correct Your Turn text is as follows:*

Repeat both tasks, Prepare Data and Publish Web Layers ... enter **June 3, 2016**. When you finish, save your project, and close ArcGIS Pro.
Tutorial 12-3: Create a map for Operations Dashboard

Build the map

Page 418, step 5

Click Done Adding Layers.

The correct step text is as follows:

Click the back arrow ← at the top left of the Add Content pane.

Tutorial 12-4: Create an operation view using Operations Dashboard for ArcGIS

Replace all of Tutorial 12-4, on pages 421–29, with the following.

Tutorial 12-4: Using Operations Dashboard for ArcGIS

A dashboard is an app intended to be used in an organization for operations management, providing multiple up-to-date visual displays, data, and statistics for understanding demand and supply patterns for goods or services or other mission-critical data. Operations Dashboard for ArcGIS is a configurable web app that you build on ArcGIS Online and use in a web browser. A dashboard can display an ArcGIS Online map that you build (such as in tutorial 12-3), attribute data lists, various charts and descriptive statistics, and queries for which the user can choose conditions.

The dashboard you will build in this tutorial has the purpose of identifying and investigating the patterns of serial graffiti artists for graffiti prevention and apprehension of graffiti artists by police. With a serial artist’s spatial and temporal patterns understood, police can target patrols to specific areas to raise the risk of arrest and thereby prevent graffiti, or even apprehend the artist in the act of painting graffiti.

The following figure shows the finished graffiti dashboard as it appears when opened. The map displays 12 weeks of the most recent graffiti data (with end date June 3, 2016, in this tutorial), symbolized by type of graffiti. If you click a graffiti symbol on the map, you get the point’s pop-up window with data. Also available in the upper-right menu of the map, besides the usual map navigation of panning and zooming, are search, bookmarks, map legend, and ability to turn layers on and off.

The side panel allows you to limit the display to any of the graffiti artists active during the past 12 weeks who left their tag names on graffiti. The default is that no artist is selected (None) so that all data displays. The top of the middle panel has the end date of the data, from the Heading web layer. The bar chart shows the frequency distribution of graffiti calls by type for the current map display, and the list is the corresponding data sorted descending by date of call and then ascending by address. If you click a row in the list, the map zooms and pans to the corresponding point and flashes the point.
The next figure shows the dashboard with artist DFK selected, where you can see that the map display, bar chart, and list all correspond to DFK, who had eight tag-type items of graffiti during the period, with the last on June 1, 2016. By clicking rows in the list, you can follow the sequence of graffiti on the map as the map zooms, pans, and flashes points.

If you have not completed tutorials 12-1 through 12-3 but wish to work this tutorial, then do the following steps and Your Turn assignment in ArcGIS Pro; otherwise, skip these steps. These steps symbolize the graffiti layer and share it and other layers as web layers on your ArcGIS Online account for use in building a web map for use in your dashboard.

1. **Open Tutorial 12-1 from Chapter 12\Tutorials, and save it as Tutorial12-4YourName.**
2. **In the Table of Contents, right-click Graffiti, click Symbology, click the Options button ➔ Import Symbology.**
3. In the Geoprocessing pane, for Input Layer, select Graffiti. For Symbology Layer, browse to Chapter12\Tutorials\Resources, and double-click Graffiti.lyrx, click Run, and close the Geoprocessing and Symbology panes when processing is finished.

Now Graffiti is symbolized with unique values of GRAFFITI_TYPE_CODE.

4. Right-click Graffiti, and click Sharing > Share As Web Layer.

5. In the Share As Web Layer pane, for Name, type GraffitiYourName (for example, GraffitiMarySmith). For Summary, type Graffiti for the most recent 12 weeks. For Tags, type Pittsburgh and Graffiti, and click Publish.

**YOUR TURN**
Similarly, share Heading and Pittsburgh map layers. For Heading, change name to Heading Your Name, and type a summary and tags of your choice. For Pittsburgh, change name to Pittsburgh Your Name, and type a summary and tags of your choice.

**Create a new dashboard**

Note that if you do not have enough time to finish this tutorial in one sitting, save your dashboard. Then when returning to do more work, in ArcGIS Online you can click your dashboard in the Contents pane, and that action will provide the option to edit your dashboard.

1. In your web browser, go to https://www.ArcGIS.com, and sign into your organizational account.

2. Go to the Contents pane.

3. Click the App Launcher button , and click Operations Dashboard > Create Dashboard.

4. For Title, type Graffiti Dashboard Your Name (where you replace Your Name with your name such as Mary Smith); for tags, type Pittsburgh and Graffiti; and for Summary, type Displays graffiti map, data, and queries for the last 12 weeks.

5. Click Create Dashboard.

ArcGIS Online creates a new blank dashboard in edit mode, ready for you to configure with resources from your ArcGIS Online web maps.

**Add a web map to your dashboard**

1. Click the Add Element button , select Map, and click Graffiti Your Name.

That action opens the Settings panel for map properties as an element of the dashboard.

2. Make selections as seen in the next figure, but do not click Done.

These selections populate a toolbar for the map in the dashboard.
3. Click the horizontal General tab, change the Name from Graffiti Your Name to Graffiti, and click Done. Your map is added as the dashboard’s only element along with its toolbar in the map’s upper-right corner.

4. Point to the map, and notice the Selector button in the upper-left corner.

5. Point to the Selector button to see the element items menu, which has Drag Item, Configure, Duplicate, and Delete.

Every element that you add to a dashboard (for example, map, query, list, or chart) has a Selector button and menu items when in edit mode.

6. In the upper-right corner of the map, click the Bookmarks button, and then click the Pittsburgh bookmark.

7. Save your dashboard.

Add the header to your dashboard

The header element (as opposed to the heading map layer) gives the dashboard a title.

1. Click the Add Element button, and select Header.

2. For Title, type Graffiti Dashboard.

You can see options to format elements, such as changing the background or text color of the header. This tutorial covers only the basics of building a dashboard, using the defaults for formatting. You can explore formatting dashboard elements in a Your Turn assignment at the end of this tutorial.

3. Click Done.

The title appears at the top of the dashboard.
Add a side panel to your dashboard

1. **Click the Add Element button, and select Side Panel.**
   The side panel has the purpose of containing one or more queries that the user can execute. Your dashboard will have a single query to display graffiti of an artist as identified by his/her tag.

2. **In the Appearance panel, for Title click the Edit button, and type Graffiti Artists.**
   Clicking an edit button exposes the rich text editor where you can format text, add an image or table, and add a hyperlink. Note that the Heading and Side Panel elements are the only two elements of the dashboard for which you cannot change location. You can change the height of the heading to Small, Medium, or Large, but the width of the side panel cannot be changed. All other elements can be repositioned and sized.

3. **Click Done.**

4. **Point to the side panel’s Selector button, and click the Add Category Selector button.**

5. **For Categories From, select Grouped Values.**
   This option forms groups using repeating values in data records such as a graffiti artist’s name.

6. **For Layer, click Change, and select Graffiti Your Name.**

7. **Type or make selections as shown next to complete the selector.**
   **Note:** For Preferred Display Type, scroll down after clicking the drop-list button to find Radio buttons. Note that the next graphic doesn’t include the top of the Selector Options panel.
8. In the Category Selector panel on the top left, click Actions.
9. Click Add Target, select Graffiti Your Name, and click Done.
This action causes the Category Selector to apply its condition, the name of an artist, to the map and show graffiti points for only that artist.
10. Click the radio button for artist DFK, and then click the far-right graffiti point to see its pop-up.
11. Dismiss the pop-up, and in the Side Panel, click None to restore all graffiti points to the map.

Add a list to display the ending data of the graffiti data

The list will display the only row of the Heading web map layer, which has the ending date of the 12 weeks of graffiti data. This date is important for informing the user of the date range of the data of the dashboard.

1. Click the Add Element button, and select List. Then for layer, select Heading Your Name.
2. In the Data Options pane, click General.
3. In General Options, for name type Ending Date List.
4. Click Done.
5. Point between the Ending Date List and the map so that you get the double-headed arrow for changing column width, and make the list column as narrow as possible so that its text, End Date: June 3, 2016, remains on one line.

You’ll place another list, for graffiti data, below the heading, in the next exercise. You’ll also place a bar chart for frequency of graffiti types in the same column.

6. Use the Pittsburgh bookmark.

Add a List to display graffiti data

1. Click the Add Element button and select List, and for layer select Graffiti Your Name.
2. For Maximum Features Displayed, type 100.
3. Click the Sort button, and select DATE_CALL > Descending.
4. Click the Sort button again, and select ADDRESS.

Graffiti data will sort first by the date of the 311 call descending (newest first), and then within date group by address.
5. Click the General tab for Data Options, and for Name, type Graffiti Data List.
6. For Title, click Edit, and type Graffiti Data for the Last 12 Weeks.
7. Click the List tab, click the Insert Attribute button, select DATE_CALL, and press Enter to get a new line in the rich text editor.
8. Click the Insert Attribute button, select ADDRESS, type a comma, press the space bar, click the Insert Attribute button again, and select ARTIST.

9. Click Done.
10. Click the Selector button for the new list, point to the Drag Item button, and drag the list below the End Date list.
11. Resize the two lists so that they appear as shown.
    Do not choose Stack for the new position. If you happen to stack the two lists so that they can be viewed by clicking tabs at the bottom of their column, drag the list again and reposition to unstack the two lists. Then both can be viewed at the same time.

Add actions to the Graffiti Data List

1. Click the Selector button of the Graffiti data List, and click Configure.
2. Click the Actions tab, click the Add Actions drop list, select Pan, and for Add Target select Graffiti.
3. Repeat two more times to add actions Zoom and Flash.
4. Click Done.
5. Save your dashboard.

YOUR TURN
Click a point in the list to see the map pan and zoom to the point, and then flash. To return to the original extent, click the same point in the list again, or use the Pittsburgh bookmark.

Add an action to the Artist Selector

1. Point to the Artist Selector, and click its Selector button in its upper-right corner.

2. Click the Actions tab.
3. Click the Add Target drop list, and select Graffiti Data List.
4. Click Done.
Now when an artist is selected in the side panel, only his/her graffiti data will be listed (corresponding to the artist’s mapped points).
5. In the Graffiti Artists pane, select DFK.
6. In the Graffiti Artists pane, select None, and save your dashboard.

Add a bar chart for graffiti type

1. Click the Add Element button, select Serial Chart, and for layer select Graffiti Your Name.
2. In the Data Options panel, for Category Field, select GRAFFITI_TYPE_CODE.
Note that Count is the default statistic, which provides frequency count for graffiti types in this case.
3. Click the Category Axis tab. For Title, type Graffiti Type Bar Chart, and for Placement, select Rotated.
4. Click the General tab, and for Title, type Graffiti Type Bar Chart.
5. Click Done.
6. Reposition the bar chart between the end date and data list. Resize the three elements as shown in the next figure so that all types of graffiti label the horizontal axis of the bar chart.

7. Save your dashboard.
YOUR TURN
Add Graffiti Type Bar Chart as a target to the Actions of the Artist Selector. Click Tommy T as the artist. The map and list show only graffiti for Tommy T, and the bar chart shows the corresponding bar chart for the mix of Tommy T’s graffiti. When finished, select None for Artists to show all data.

Add an extent action to the map

The extent action for the map will limit the bar chart and graffiti data list to only those points in the current map extent. This configuration is useful for an investigator who wants to study the graffiti of a neighborhood.
1. **Click the Selector button of the map, and click Configure.**
2. **Click the Map Actions horizontal menu item.**
3. **Click Add Target, and then click Graffiti Data List.**
4. **Click Add Target, and click Graffiti Type Bar Chart.**
5. **Click Done.**

Now the bar chart and data list show data for only the current map extent.
6. **Use the Central Business District bookmark.**
The bar chart and graffiti list show only results for the Central Business District map extent.
7. **Save your dashboard.**

Add a date selector

Often, investigators will want to study recently reported graffiti instead of the entire 12-week period available. For this purpose, you will add a date selector. The user can then select a starting date for the displays from the available 12 weeks of data.
1. **Click the Selector button of the Graffiti Dashboard heading, and click the Add Date Selector button.**
2. **For Type, select Date Picker.**
3. **For Operator, select “is or is after.”**
4. **For Label, type Beginning Date of Graffiti Data.**
5. **For Name, type Beginning Date Selector.**
6. **Click the Actions tab.**
7. **Click Add Target, select Graffiti Your Name, and for Target Field select DATE_CALL.**
8. **Similarly, add targets for Graffiti Data List and Graffiti Type Bar Chart, selecting DATE_CALL for Target Field.**
9. **Click Done, save your dashboard, and try out the date selector for 5/24/2016.**
10. **Scroll down the Graffiti Data List to see that the earliest CALL_DATE is 5/24/2016.**

YOUR TURN
Try changing map extent, graffiti artists, and beginning date to see that all work together as desired.
Use and share your dashboard

1. **Click the Home button**, and select Content.
2. **Click Graffiti Dashboard Your Name.**
   Here, you have options to view the dashboard as any user would, edit the dashboard, and share it.

   ![View Dashboard]

   ![Edit Dashboard]

   ![Share]

3. **Click Share, and if you are a member of an organization, you will see a check box with your organizational name that you can select if desired.**

   If you belong to any groups, you could share your dashboard with any of them. **Note:** To share your dashboard, you must also share input web map layers with your organization or groups: GraffitiYourName, HeadingYourName, and PittsburghYourName.

4. **View your dashboard.**

   You can copy your dashboard’s URL from your browser and send it to others so that they can open and use it.

---

**YOUR TURN**

In edit mode, explore and use some options to format some of your dashboard elements. For example, for your header panel, change its size, text color, and background color.
Chapter 13
Operations management with GIS: Graffiti Removal System

Tutorial 13-1: Build the Identify Graffiti for Removal model

Open the Tutorial 13-1 project

Page 433, step 2
Use the Pittsburgh bookmark.

The correct image is as follows:

Build a model to query sites for graffiti removal

Page 434, step 2
In the Catalog pane, rename Model as a. Identify Graffiti for Removal, and hide the Catalog pane.

The correct step text is as follows:
In the Catalog pane, right-click Model, and click Properties. For Name, type IdentifyGraffitiForRemoval; for Label, type a. Identify Graffiti for Removal, click OK, and save your model.

Page 435, step 6
For Input features, select GraffitiCalls, and for Output Layer, type GraffitiForRemoval, and create the query expression as shown in the figure.

The correct step text is as follows:
For Input features, select GraffitiCalls, and for Output Layer, type GraffitiForRemoval, click New Expression, create the query expression as shown in the figure, and at the bottom of the form, click OK.
Page 435, step 8
Right-click the output, GraffitiForRemoval, and click Add to Display.
Delete this step.

Page 435, step 10
Turn off the GraffitiCalls layer, and close the Model message window.
The correct step text is as follows:
Close the Model message window.

Page 436, Symbolize output
Replace the steps of this exercise, on pages 436–37, with the following.

1. Add the Apply Symbology From Layer tool to your model below the Make Feature Layer process, and open it.
2. Drag GraffitiCallsForRemoval to Apply Symbology From Layer, and click Input Layer.
3. Open Apply Symbology From Layer, browse to Chapter13\Tutorials\Resources, and select Graffiti.lyrx. The Graffiti.lyrx layer file has unique symbols for GRAFFITI_TYPE_CODE, plus labels for GraffitiCallsForRemoval. The labels display work time estimates (minutes) for graffiti removal at each site.
4. Click OK, close the Geoprocessing pane, and rearrange and resize elements of the model to improve its appearance.

Note that process inputs and outputs must have unique names in a model, even when they refer to the same feature class or map layer. It does not matter, for example, if your model has GraffitiForRemoval (3) instead of GraffitiForRemoval (2), as long as the names are unique.
5. **Right-click GraffitiForRemoval (2), and click Parameter.**
   This step will cause the new layer to be added to the map when you open the model to run it from the user interface that ModelBuilder builds for the model.

6. **Right-click the Apply Symbology From Layer process, click Run, and close the message window when the model is finished running.**

7. **Right-click GraffitiCallsForRemoval (2), and click Add To Display.**

8. **In your map, right-click GraffitiForRemoval, and click Label.**
   The labels, from Graffiti.lyrx, show the estimated time for graffiti removal, provided by the Public Works supervisor.

9. **On the ModelBuilder tab, click Save to save your model, and then close it.**
   Note that if you need to edit your model again, right-click it in the Catalog pane, and click Edit.
Create a route

Page 440, step 4

Make selections as shown for the Make Route Analysis Layer process.

The correct image is as follows:

![Make Route Analysis Layer](image)

Add locations

Page 441, step 1

Add the Add Locations tool to your model three times, lining up the processes vertically.

The correct step text is as follows:

Add the Add Locations tool to your model three times, lining up the processes vertically; then close the Geoprocessing pane.

Page 441, step 2

Open the first Add Locations process, and make your selections as shown.

The correct step text is as follows:

Open the first Add Locations process, and then for Input Network Layer, select Route, and for Input Locations, select Garage.
Tutorial 13-3: Build the Record Route Results model

Configure the Directions process

Page 445, step 2

For Input Network Analysis layer, select Route; for the Output File, type Text, and then type Route%RouteName% as shown.

The correct step text is as follows:

For Input Network Analysis layer, select Route; for the Output File, select Text, and then type Route%RouteName% as shown.

The correct image is as follows:

![Directions Image]
Configure the first Calculate Field process

Page 447, step 2

Type or make your selections as shown.

The correct image is as follows:

Page 447, step 5

Open the GraffitiForRemoval attribute table, and sort ROUTE_NAME descending to see that the process worked.

The correct step text is as follows:

Open the GraffitiForRemoval attribute table, and sort ROUTE_NAME2 descending to see that the process worked.
Configure the second Calculate Field process

Page 448, step 3

Open Chapter13\Tutorials\Resources\Tutorial13-3CodeBlock.txt, and copy and paste the text as shown.

The correct image is as follows:

```
import datetime

def getdate(thedate):
    dd = datetime.date(year=int(thedate[0:4]), month=int(thedate[4:6]), day=int(thedate[6:8]))
    ds = dd.strftime('%m/%d/%Y')
    return ds
```

```
getdate('12092015')
```
Tutorial 13-4: Update data using Collector for ArcGIS

Open the Tutorial 13-4 project

Page 451, step 2

*Use the Pittsburgh bookmark.*

The correct image is as follows:

![Map with GraffitiCalls and World Street Map]

Rename a feature class

Page 454, step 6

*Symbolize GraffitiCallsYourName to have a Circle 1 point symbol and blue color and size 1.*

The correct step text is as follows:

*Symbolize GraffitiCallsYourName to have a Circle 1 point symbol and dark-blue color and size 5.*

Publish a web layer

Page 454, step 1

*In the Contents pane, right-click GraffitiCallsYourName, and click Share as Web Layer.*

The correct step text is as follows:

*In the Contents pane, right-click GraffitiCallsYourName, and click Sharing > Share As Web Layer.*

Page 455, step 2

*Make or type the selections as shown; for name, select GraffitiCallsYourName.*

The correct step text is as follows:

*In the Share As Web Layer pane, for Summary, type Up-to-date graffiti calls, and for Tags, type Graffiti and Pittsburgh.*
Set the editing option for a web layer in ArcGIS Online

Page 455, step 2

In My Content, point to GraffitiCallsYourName feature layer, click its arrow, and click View Item Details.

The correct step text is as follows:

In the Contents pane, click the GraffitiCallsYourName feature layer.

Create a map in ArcGIS Online

Page 456, step 1

Click the Options button at the top left of the current web page, and then click Map.

The correct step text is as follows:

On the Settings page, scroll up, and in the main menu, click Map.

Page 456, step 3

For In, select MyContent; for GraffitiCallsYourName in Results Found, click Add.

The correct step text is as follows:

Click GraffitiCallsYourName > Add To Map.

Page 456, step 4

Click Done Adding Layers.

The correct step text is as follows:

In the upper-left panel, click the back arrow of My Content, and then click the Show Map Legend button.

Page 456, step 5

Change the basemap to Streets.

The correct step text is as follows:

Click the Basemap Gallery button, and change the basemap to Streets.

Add a filter

Page 457, step 1

In the Contents pane, for GraffitiCallsYourName, click the Filter button.

The correct step text is as follows:

For your map, click the Show Contents of Map button, and for GraffitiCallsYourName, click the Filter button.

Get started with Collector for ArcGIS

Page 460, step 4

Tap My Maps, and then tap your map, Graffiti Calls for Supervisor Review, to open it. You do not need to establish location services for this tutorial.

The correct step text is as follows:

Tap Graffiti Calls for Supervisor Your Name to open it, don’t allow Collector to access your location, click OK, and zoom out and pan to see the seven graffiti calls.
Page 461, Edit graffiti calls using an Apple device

Replace the steps of this exercise, on pages 461–62, with the following.

1. Tap the northernmost graffiti call point to select it.
2. Tap the Options button … in the lower-right corner of your screen, and tap Edit.

Suppose that this graffiti call not only needs its attributes updated but also needs its location corrected.

3. Zoom in, drag the location target crosshairs to a new location about a block away from the original location, and click the Update Point button.
4. Tap the DATE_APPROVED cell, and then tap today’s date.
5. Tap the GRAFFITI_TYPE_CODE cell, and select Tag.
6. Tap the REMOVAL_TYPE_CODE, and select Sandblast.
7. Tap WORK_TIME_ESTIMATE, type 30, and tap Next.
8. Tap Submit.

Collector saves your edits in your ArcGIS Online feature class.

Use a hosted feature layer for ArcGIS Pro processing

Page 464, step 6

In Portal, click My Content, then click GraffitiCallsYourName, and click OK.

The correct note text for this step is as follows.

Now ArcGIS Pro has the version of GraffitiCallsYourName that was updated by Collector. You could add to or modify the same GraffitiCallsYourName feature layer using ArcGIS Pro. You would have slightly slower response times if you completed the steps in ArcGIS Pro because of the remotely located feature layer.

Page 464, step 7

In the Contents pane, expand GraffitiCallsYourName to see its GraffitiCallsYourName feature layer.

Delete this step.