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Introduction
This supplemental booklet has updates, changes, additions, and corrections for GIS
Tutorial for Crime Analysis, first edition (2012). There are many reasons for this Supplement
for ArcGIS 10.2 booklet. First, websites are frequently updated, so workbook steps or readings
that have you refer to or use websites sometimes need corresponding changes. Also, the
developers of ArcGIS for Desktop provide quarterly software releases with new and revised
functionality. Some of these software changes need corresponding changes in workbook
steps. This booklet is based on the ArcGIS 10.2.2 for Desktop Advanced license. Finally, there
are always some errors or unclear workbook instructions discovered by users, such as
yourself, that simply need to be fixed. Please e-mail either author (gorr@cmu.edu or
kurland@cmu.edu) with any new errors or problems that you encounter, and you’ll get a
quick response, either a thank-you or some help.
Here’s how to use this booklet. When working through a chapter of the workbook, first
scan this booklet’s corresponding section (identified by chapter number and title), looking for
changes as provided by page and step numbers of the workbook. A good practice is to make a
mark in the workbook for each change or addition in this booklet, and then when you come
to a marked location in the workbook, read and use the material in this booklet. Alternatively,
just keep both the workbook and this booklet open, checking for changes as you work.
There are no tutorial steps using ArcGIS in chapter 1, so the booklet starts with chapter 2.
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Part 1
Working with crime maps

Chapter 2
Changes for Exploring ArcGIS Desktop
Page 16, “Add and remove layers in the table of contents,” step 1

Replace “expand the My Computer directory” with “Expand the Computer directory”.
Page 17, map at the top of the page

Note: Although the map in the book shows all of Pittsburgh, your map should still be
zoomed into Pittsburgh’s point. If you have the wrong map extent on your computer, you can
use navigation tools on the Tools toolbar to get to Pittsburgh’s point—the blue arrows to go
to previous or next extent, and the blue and green world button to go back to all of Pittsburgh
(full extent).
Page 17, step 4

Note: The Zoom To Nearest Cache Resolution option is no longer available. This would
have zoomed to the nearest, best map extent given the quality of the image.
Page 18, Your Turn

Note: Shaded Relief and USA Topo Maps are no longer available. Instead, try the
Topographic basemap. Although you are using the File > Add Data > Add Basemap option, you
can also try the File > Add Data > Add Data From ArcGIS Online option, which allows you to
search for data from Esri’s vast collection of map layers as supplied by Esri, spatial data
vendors, and users.
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Page 20, Your Turn

Note: To read and access data, click the Description tab in ArcCatalog. If an Upgrade
Metadata window appears, click Yes (then wait a moment) > OK > Close to upgrade the
internal storage of Blocks metadata.
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Chapter 3
Changes for Using crime maps
Page 37, “Create new bookmark,” step 2

Replace “Create” with “Create bookmark”.
Page 37, “Create new bookmark,” step 4

Replace “Manage” with “Manage Bookmarks”.
Page 37, “Export map,” step 7

Replace “My Computer” with “Computer”.
Page 40, Your Turn

Note: You can copy the minimum or maximum scales (which are the same) from the
General tab of Burglary Count: July 2008 or Burglary Level: July 2008 and paste to the
appropriate Out beyond or In beyond fields to set the visible scale ranges of additional map
layers.
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Chapter 4
Changes for Designing and building crime maps
Page 60, step 3

Also, make the street outline width 0.75.
Page 63, step 6

The query that you build will have additional zeros for date values, to represent times.
There are no time values in the data. Your query should look like this:
DateOccur >= date '2008-06-14 00:00:00' AND
DateOccur <= date '2008-07-04 00:00:00' AND
Hierarchy >= 1 AND
Hierarchy <= 7
Page 67, “Set field properties,” step 1

A better instruction for clearing fields is to clear the check boxes from OBJECTID through
ARC_STREET to turn off the labels for the first seven fields.
Page 72, Create “change map” data using spreadsheet software (optional exercise), step 1

Before you open BurlarySeriesComplete200810.xlsx, you have to save and close ArcMap
because ArcMap has control of that spreadsheet and Windows won’t let you open it in
another package. Then open whatever version of Microsoft Excel you have and complete the
step.
Page 74, step 8

Rename the tab at the bottom left of your worksheet BurglarySeriesCompleteChg200810.
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Page 75, step 2

Your query should look like this:
DateOccur >= date '2008-07-01 00:00:00' AND
DateOccur <= date '2008-07-31 00:00:00' AND
Hierarchy = 5
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Part 2
Conducting crime analysis

Chapter 5
Changes for Querying crime maps
Page 100, “Obtain statistics on crimes within a buffer area,” step 2

Replace the figure with the one below. Also note that 27 records, not 26 records, are
selected.
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Page 101, step 4

Note: If you get an error message with ERROR 000210, change some of your
environmental settings. Click Geoprocessing > Environments > Workspace, and set both the
Current Workspace and Scratch Workspace
to \EsriPress\GISTCrime\MyExercises\Chapter4\Chapter4.gdb.
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Chapter 6
Changes for Building crime map animations
Note on this entire chapter: make changes if you are running ArcGIS for Desktop 10.2.2. Otherwise if using an
earlier version, just work the tutorial as is.

ArcGIS for Desktop 10.2.2 has a bug in its Time Slider and similar Time View graphical
interfaces, so if you are running that version of ArcGIS follow instructions below carefully. Do
not select Time Slider or Time View at any time!
Page 111, do not do steps 1 and 2! Skip them. Start with step 4.

Note: The Time View tab used in these steps has a bug. If you select this tab, your
computer will freeze, and you’ll have to close ArcMap and start over.
Page 111, replacement for step 5

5. Do not click the Calculate button. Check to make sure that the “By number of
frames” option button is selected and that 34 is the value in that field. If the
value is not 34, type 34 and press the Tab key. Change the Frame duration
value to 0.5 seconds and press the Tab key.
Page 112, Your Turn

Do not use the Time Slider. Instead, play the animation using the controls on the
Animation toolbar. Change the frame duration from 0.5 to 1.0 seconds using Animation
Controls Options to study the pattern more easily.
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Pages 113–14, “Add XY layer,” replacement for steps 1–3

1. Open Catalog and expand the tree to find ATMDateStamp.cvs.
2. In the Catalog tree, right-click ATMDateStamp.cvs and click Create Feature
Class > From XY table. In the Create Feature Class From XY Table window, set
the coordinate system
to NAD_1983_StatePlane_Pennsylvania_South_FIPS_3702_Feet. Save the
output shapefile as XYATMDateStamp.shp to the Chapter6 folder. Click OK.
Drag XYATMDateStamp.shp from Catalog to the table of contents. Close
Catalog.
3. In the table of contents, double-click XYATMDateStamp.shp, click the
Symbology tab, and click the Symbol button. Change the symbol to Circle 1,
Size 1, No Color. Click OK.
Page 116, Your Turn

For the first bullet, make sure that the time properties for Serious Crimes 4 Weeks
Context Hierarchy are not enabled.
For the third bullet, make sure that the unit for Keyframes is Days. Each time you make a
new animation, set keyframe units to days.
For the fourth bullet, select “By number of frames”, and if the value is not 366, type 366 in
the corresponding field. Then select “Play only from”, and type 172 to 195, corresponding to
July 6 through July 27. If the time slider did not have a bug, you would have a graphical way of
selecting values such as the range 172 through 195.
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Page 117, Your Turn

Use the new instructions for the page 116 Your Turn given on the previous page to do this
Your Turn. Do not use the Time View window, but instead play the animation with the
Animation toolbar controls. Create an XY feature layer from PinMapDateStamp.csv in the
Chapter6 folder in FinishedExercises.
Page 118, skip the “Explore emerging hot spot” exercise

Using the Time View tab would freeze your computer.
Page 119, step 7

Note: Do not enable time properties for FiremanWay.shp. You’ll use it in a group
animation that has a different way of displaying layers in an animation.
Page 120, skip steps 3–8 and do this work-around

Note: The Time View graphical interface would crash your computer. Instead, use the
following work-around, in which the instructions directly give you the start and end points for
displaying FiremanWay.shp, from just before to just after the hot spot is active in that area.
3. In Animation Manager, click the Keyframes tab and type 0.480 for the End
Fade In time and 0.520 for the End Fade Out time so that the three values in
the Time column are 0.000, 0.480, and 0.520.
4. Play the animation using the Animation toolbar controls.
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Chapter 7
Changes for Conducting hot spot analysis
Page 131, “Create size-graduated point markers,” step 3

Note: After the Collect Event tool finishes running, you may notice a warning in the lower
right of your computer screen. Click it to open the warning message. It says that there was a
problem reading 214 of the drug call events, but these are just the records that were not
geocoded (because either the corresponding police records had poor address data or the
street centerline layer used in geocoding had some errors) and thus are not on the map.
You’ll learn about geocoding in chapter 9.
Page 138, “Create contour polygons defining a drug hot spot”

Note: The steps in this exercise create polylines, and not polygons as stated. The reason is
that some contours may not form closed polygons, and you can find one of these in your
output after step 5. Consequently, you cannot select features from other map layers, such as
Drug Calls, using the contours.
Page 139, step 5

Instead of opening the HotSpotContour table, with a contour selected just press the
Delete key.
Page 141, “Create block centroid map layer,” step 4

To click Import, click the Add Coordinate System button
Pittsburgh.gdb, and click Blocks > Add > OK > OK.

, click Import, navigate to
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Part 3
Building a crime mapping and analysis system

Chapter 8
Changes for Assembling jurisdiction maps
Pages 154‒157, replacement for tutorial 8-1

Note: This replacement, for page 154 to the middle of page 157 of tutorial 8-1, has you
use the new Census Bureau website.

Tutorial 8-1 Downloading and preprocessing basemaps
The first task for assembling a jurisdiction map is to download free basemaps and census
data. You need to process some of the downloaded files before using them, but those
instructions will follow in subsequent exercises later in this chapter.

Download TIGER basemaps from the Census Bureau website
1. Start a web browser, such as Internet Explorer, and go to www.census.gov.
Click to open the website.
2. On the horizontal navigation bar, hover over Geography, and from the
resulting drop-down list, click the Maps & Data link, and then click the TIGER
Products link, in the left panel under Data.

14

3. Click TIGER/Line Shapefiles in the Product column under “which product
should I use?” Then click the 2009 tab > Download > Web Interface.
A shapefile is a simple map file format designed by Esri that is in wide use.
4. In the state- and county-based shapefiles panel on the right, select
Pennsylvania and click Submit. Then select Allegheny County and click
submit.
5. Select files as shown in the figure below.
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6. Click Download Selected Files > Open. Extract all files to the Downloads
subfolder in the Chapter8 folder in MyExercises.
The result is five compressed files in a ZIP folder called multiple_tiger_files with
subfolders 42_Pennsylvania, then 42003_Allegheny_County, and finally zipped files as
follows:
tl_2009_42003_areawater.zip
tl_2009_42003_cousub00.zip
tl_2009_42003_edges.zip
tl_2009_42003_tabblock00.zip
tl_2009_42003_tract00.zip

7. Open a Computer window and extract each of the compressed files to the
Downloads folder (double-click each zipped file and click the Extract all files
button).
8. Delete the multiple_tiger_files folder that has the compressed files to save
space on your hard drive.
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9. Look in a Computer window to see that each shapefile consists of five data
files.
For example, tl_2009_42003_areawater.shp is the shapefile for water features and so
carries the .shp file extension. The .shp file stores the graphic features, the .dbf file
stores the attribute table, the .prj file stores metadata on the coordinate system or
projection of the map layer, and the .shx file contains an index to speed up processing
of the shapefile. The fifth file is an XML document that has metadata for the layer (try
double-clicking it to see the metadata). Note that the “42” in the file names is the
Census Bureau code for Pennsylvania, and “003” is the code for Allegheny County.

Download census data
Census data for 2000 and 2010 and American Community Survey (ACS) data is available
from the same web pages of the Census Bureau website. The Census Bureau’s SF1 (Summary
File 1) data provides basic census data on population, housing units, and households. This
data is available for all census levels, including tracts, block groups, and blocks. For detailed
data on education, income, transportation, and other subjects, you can download samplebased estimates from the ACS. In the 2000 and previous censuses, such data was collected in
the census long form randomly from one out of six households and was called SF3 (Summary
File 3) data. Now the Census Bureau collects ACS data monthly—approximately 3 million
housing units annually receive a survey similar to the old long-form questionnaire. Annual,
three-year, and five-year estimates produced from ACS samples are available. To learn more
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about the ACS, visit the website at www.census.gov/acs/www/. In this tutorial, you extract
2000 SF3 data on poverty at the tract level for Allegheny County.

Get started on downloading census data
1. Using your browser, go to http://factfinder2.census.gov.
2. On the horizontal toolbar, click ADVANCED SEARCH. Then click the
Geographies button.

3. Click the Name tab of the Select Geographies window; type Allegheny County;
click Allegheny County, Pennsylvania, in the drop-down list; and click Go.
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4. In the Geography Filter Options panel, click Census Tract.

5. In the Geography Results panel, select the check box for All Census Tracts
within Allegheny County, Pennsylvania, and then click Add.

6. Close the Select Geographies window.
Your selection should be as follows. The Search Results panel displays data collections
that are available at the census tract level.
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Finish up downloading census data
1. In the Refine your search results text box, type P087 and click Go. Then
select the check box for Poverty Status in 1999 By Age.

2. Click the Download button > OK > Download and open the downloaded
compressed file.
3. Extract all files to the Chapter8/Downloads folder of MyExercises.
The DEC_00_SF3_P087_with_ann.csv file has the SF3 data.
4. Close your browser.

Preprocess census data in Microsoft Excel (optional exercise)
The data you just downloaded needs to be put into table form, with the top row
containing attribute names and all the remaining rows containing raw data only. Instead, the
data has two identifying rows at the top, and the remainder of the rows have raw data. You’ll
need to replace these two rows with one that has self-documenting attribute names. Of the
many columns available in the data table, you only need the first half and thus will delete the
rest. The easiest way to carry out these tasks is to open the data in Microsoft Excel and do the
work there.
1. Start Microsoft Excel.
2. Click File > Open.
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3. In the open window, change “Files of type” to All Files (*.*), browse to the
Downloads folder in Chapter8 in MyExercises, and double-click
DEC_00_SF3_P087_with_ann.csv.
4. Click the sheet selector button (to the left of the A column header and above
the row 1 selector) to select the entire sheet, and then double-click between
any two column headings to automatically resize all column widths to fit the
data so that you can read all the cell contents.

5. Clear your selection by clicking in any cell. Then delete the GEO.ID and
GEO.display-label columns, identified in row 3, by right-clicking their
column selectors one by one and clicking Delete. Then using identifiers in
the second row, delete columns starting with VD10 and all remaining
columns to the right that have data.
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6. Rename row 1 attributes by replacing the values as follows:
GEO_ID2

Tract

VD01

Pop

VD02

PopPov

VD03

PopPovU5

VD04

PopPov5

VD05

PopPov6T11

VD06

PopPov12T17

VD07

PopPov18T64

VD08

PopPov65T74

VD09

PopPov75U

7. Select row 2, right-click in the selection, and click Delete.
8. Double-click the tab at the lower-left corner of the spreadsheet that has the
label DEC_00_SF3_P087_with_ann, and type AllCoPoverty to give the tab a
new label.
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9. Click File > Save As. Change the file name to Poverty, change the Save As type
to Excel Workbook, and click Save. Then close Microsoft Excel.
Start working in the book on page 158 with the section “Project coordinates for the
Census Bureau All Lines shapefile” and complete the chapter.
Page 159, replacement for step 5

5. Expand the Projected Coordinate Systems tree to State Plane > NAD 1983
(CORS96) (US Feet), and click NAD 1983 (CORS96) StatePlane Pennsylvania
South FIPS3702 (US Feet). Then click OK.
Page 168, after step 4 at the top of the page, add new steps 5 and 6.

If you export the tracts feature layer as it is now with joined data, the exported layer will
have tract data joined permanently, instead of just joined on the fly as it is now. Permanently
joined data is required in newer versions of ArcMap to use the Field Calculator on page 170.
5. Right-click PennHillsTracts, click Data > Export Data, save the output
as PennHillsTracts2 in Chapter8.gdb, and click OK > Yes.
6. Open Catalog, delete PennHillsTracts, rename PennHillsTracts2
as PennHillsTracts, and in the table of contents, change the name
PennHillsTracts2 to PennHillsTracts.
If you open the attribute table of PennHillsTracts, you’ll see that attribute names for
the joined census data are no longer qualified with the prefix of the joined table name,
AllCoPovberty$. This means that the census data attributes are permanently joined in
the PennHillsTracts attribute table.
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Page 170, step 5

Note: The CarBeat column is no longer qualified with a prefix source name because you
permanently joined the census data to the tract feature class.
Page 171, “Dissolve polygons,” figure and step 5

Note: Attributes in the figure and step are no longer qualified with a prefix source name
because of the permanent join.
Page 173, “Assign aliases to attributes,” steps 2 and 3

Note: Again, attribute names are no longer qualified.
Page 174, after step 9

Add a new step 10. This step has you change the full extent of the map to Penn Hills, so if
you need to zoom to all of Penn Hills it’s convenient to use the Full Extent button.
10. Zoom so that Penn Hills fills your map window. Right-click Layers in the
table of contents. Then click Properties > Data Frame tab > Other option
button in the Extent panel (it defaults to the current extent), and click OK.
Page 177, at the end of step 3

On the Editor toolbar, click the Create Features button (last button on the right), select
CarBeatsCustom in the Create Features window, and close the Create Features window.
Page 178, Your Turn

Note: if you get stuck at a point and cannot continue tracing, click on the traced part near
the end of the trace, click near the end trace on the undigitized side, and then keep tracing.
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Page 179, “Set up to digitize lines for block watches,” replacement for step 5

5. On the Editor toolbar, click the Create Features button, select BlockWatches
in the Create Features window, and then close the Create Features window.
Page 180, step 4

Note: You don’t have to trace the same street segment twice. When finished with a
segment, click the end point. Then go to a new starting point, click, and start digitizing again.
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Chapter 9
Changes for Preparing incident data for mapping
Page 193, replacement for steps 2–5

2. In the Address Locator Properties sheet, expand Place Name alias tables and
click the builder button at the right.
3. Browse to the Data\Locators folder and double-click PittsburghAlias.csv.
4. Click in the Alias Field row of the property sheet, click the arrow at the right,
and click Alias.
5. Expand the remaining properties in the tree and examine them, making the
change as seen in the figure on the next page.
Replace the figure at the bottom of page 193 with the one on the next page. The
“Match with no zones” property with the value of Yes is appropriate for a police
jurisdiction with one municipality, such as the case with the Pittsburgh Bureau of
Police. County police, on the other hand, have multiple municipalities and likely will
have repeating street addresses (e.g., 100 Main St.). Then the street map would need
CityLeft and CityRight attributes as zones, and the incident data would need to have
City as an attribute and have the same city spellings as in the street map.
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Page 194, start of the “Batch address match incident data” exercise

Note: The batch geocoding algorithm is now much more efficient. Instead of taking 20
minutes to geocode the over 51,000 records, it takes only about four or five minutes, so you
can let it finish running instead of canceling it in step 5.
Page 194, step 2

Note: If the PittsburghTIGER address locator is not in the Choose an Address Locator to
Use panel, click Add, browse to Chapter9.gdb, and double-click PittsburghTIGER.
Page 194, replacement for the figure at the bottom of the page
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Page 194, step 5

Let the geocoding algorithm finish instead of canceling it. You’ll find that 84% of records
are matched and mapped, while 1% have tied address candidates and 15% are unmatched.
Tied cases had two or more candidate addresses on the street map with equally good
matches, and ArcMap selected one arbitrarily for mapping. Click Close when you are finished.

Page 195, “Batch address match incident data,” steps 6–8

Esri software developers are always improving the complex geocoding algorithm, making
it faster and more accurate, so the geocoded map layer that you just created is different from
the one created when this book was written. To minimize changes in the following exercises,
remove OffenseMaster20081031 from the table of contents, and add and use
OffenseMaster20081031b as instructed. Notice that only 82% of the records are matched in
OffenseMaster20081031b, another indication of the improvement in the current geocoding
algorithm.
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Page 201, replacement assignment for Your Turn

Try finding a few more of the alias addresses.
Page 203, Your Turn, replacement for the last paragraph

Right-click the PittsburghTIGER locator of Chapter9.gdb in Catalog, click Rebuild, and click
OK. Rename the rebuilt locator PittsburghTIGER2.
Page 203, skip steps 2–4

The current geocoding algorithm will yield different results from those in the book that
were done with an earlier version of ArcGIS for Desktop. So instead, remove
OffenseMaster20081031b, and add OffenseMaster20081031c for further processing as
instructed in steps 1 and 5.
Page 204, “Rematch addresses interactively,” replacement for steps 3 and 4

3. Scroll down and click in the first of two rows with 1 GERBER AV. The street
number is way off according to the incident report—a typo. It should be
3501.
4. In the Full Address field on the lower right of the Interactive Rematch
window, type 3501 to replace the 1 and press the Tab key.
Page 206, Your Turn

The match statistics with ArcGIS 10.2.2 are as follows:
Matched: 171 (90%)
Tied: 0 (0%)
Unmatched: 19 (10%)
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Page 211, replacement for the top figure on the page

Page 211, Your Turn

The hint doesn’t work. You will have to re-create the query.
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Chapter 10
Changes for Automating crime maps
Page 229, “Create and fix bugs in Edit mode,” step 2

Instead of typing ?, type 2 at the end of the first occurrence of DateOccur to produce
“DateOccur2” and create a bug.
Page 230, step 5

ArcMap no longer provides a separate error message. Leave the Public Map run window
open and scroll down to see the error message. When finished, close the window.
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Page 230, step 6

There’s no drawing errors window to close, so skip that part of this step and delete the 2
in “DateOccur2”.
Page 230, step 8

After deleting the final single quotation mark in the value for StartDate, it will be
date '2008-07-15
Page 230, step 9

Note: Again, ArcGIS no longer provides a separate error message, but you can find the
error information in the Public Map run window.
Page 232, before starting the “Build ‘geocoding addresses’ process”

Geocoding requires three elements: an input table with addresses, streets, and a locator
file that stores parameters for the geocoding process. While in model edit mode of a model,
the input table can be an external file, such as a Microsoft Excel spreadsheet, and geocoding
will work, but when running the model from the user interface, the input table must be
imported into the ArcGIS format for a table. So now you will do the importing to enable the
interface to run later:
•

Open Catalog and expand the tree to Chapter10.gdb.

•

Right-click Chapter10.gdb and click Import > Table (single).

•

Complete the Table to Table process as shown on the next page. When
you are finished, click OK.
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Page 233, replacement for the figure at the top of the page

Page 233, “Build spatial join process,” step 4

Note: You can click View and 75% or another size for your model to make it more compact
on your screen.
Page 235, “Build append process,” step 2

In the Append tool dialog box, also click No_Test for Schema Type.
Page 236, “Run model,” step 2

If geocoding does not work in your model, open the property sheet for the
PittsburghTIGER2 locator in Chapter9.gdb of FinishedExercises\Chapter9 and make sure that
the Geocoding options > Match with no zones property is set to Yes. Then try again if you had
to change the property to Yes.

