Getting to Know ArcGIS Pro
Supplement for ArcGIS Pro 2.4
Getting to Know ArcGIS Pro, second edition, published in 2019, was written and
tested on ArcGIS® Pro 2.3. Since then, ArcGIS Pro 2.4 has been released, with
expanded capabilities and a slightly different user interface. In this supplement,
we provide updates and corrections to steps and workflows that will help you
complete the exercises in the book. We recommend that when working through a
chapter of the workbook, you first look through the information provided for that
chapter in this document. A good practice is to mark the spot in the workbook for
each change or addition. When you come to the mark, you can refer to the
supplement.
Because ArcGIS™ Online is a dynamic website, the interface shown in this book
may differ from what you see displayed.

Chapter 1
Introducing ArcGIS
Exercise 1a: Explore ArcGIS Online
Section: Explore a public map
•

On Your Own (page 14) — Users are asked to click the Features tab to learn more about how
developers and professionals use ArcGIS Online. This information is now available by clicking the
Learn more about ArcGIS Online link.

•

In this section, users are asked to search for and open the Geology of United States map in Map
Viewer. The map contains the USA Geology layer, which is no longer available. To explore
ArcGIS Online maps and basic functionality, users may consult the following introductory
materials provided by Esri:
➢ Try ArcGIS Online (a Learn ArcGIS path that provides story maps, tutorials, and articles on
building maps, analyzing data, and sharing stories using ArcGIS Online)

Section: Sign in and join an organization
•

Step 5 (page 29) — Users are asked to search for a web map named Pedestrian and Bicycle
Accidents – Wilmington, DE. Numerous copies of the map may appear in the results. Users
should click the title of the copy owned by michaellaw.

Section: Configure map pop-up windows
•

Step 9 (page 40) — Users are asked to click Save Pop-up. After doing so, they should click OK.

Chapter 2
A first look at ArcGIS
Exercise 2a: Learn some basics
Section: Modify map contents
•

Step 3 (page 53) — Users are asked to collapse all legends in the Contents pane. To do so more
efficiently, users should press and hold Ctrl and click a single expander arrow.

•

Step 8 (page 55) — Users are asked to highlight the Layers1 map title in the Contents pane.
Users may see a slightly different name, such as Layers or even Layers2. A slightly different map
title will still work properly in the exercise.

Exercise 2b: Go beyond the basics
Section: Measure distances
•

Step 1 (page 68) — Users are asked to zoom to South America on the map and then to locate
the Measure tool on the ribbon. The tool can be found on the Map tab, in the Inquiry group.

•

Step 2 (page 68) — Users are asked to set values in the Measure tool window. The window is no
longer called Measure, and the functionality is different. The instructions should now read as
follows:
➢ In the Measure Distance window, from the drop-down list, choose Miles.

•

Step 3 (page 69) — Users are asked to measure the distance between two points on a map. The
following screenshot shows the newly named Measure Distance window.

•

Step 4 (page 69) — Users are asked to clear the search results of a previous measurement. The
Clear Results button is located in the middle (not at the top) of the Measure Distance (not the
Measure) window.

Chapter 3
Exploring geospatial relationships
Exercise 3a: Extract part of a dataset
Section: Select features by attributes
•

Step 2 (page 92) — Users are asked to create a selection in which the state name attribute value
equals Illinois. The Select Layer By Attribute tool pane has changed. The Layer Name Or Table
View parameter is now called the Input Rows parameter, as shown in the screenshot. The
instruction should read as follows:
➢ For Input Rows, select the us_cnty_enc shapefile. For Selection type, maintain the default
New selection (click the down arrow to see additional options).

•

Step 3 (page 93) — Users are asked to build an attribute query. The expression builder now
operates somewhat differently. The instruction should read as follows:
➢ Under Expression, click New expression, and then choose the correct options to create the
following expression: STATE_Name is Equal to Illinois.

•

Step 4 (page 93) — Users are asked to run the Select Layer By Attribute tool after building an
expression and setting parameters. It is no longer required to click Add to add the expression to
the tool before running it. Users only need to click Run.

Section: Export the selection to a new dataset
•

Step 2 (page 94) — Users are asked to create a new feature layer from a selected set of
counties. To do so, they should no longer click the Export button to access the Export Features
and Export Table tools. The revised instruction should read as follows:
•

•

On the Data tab, click the Export Features button.

Step 4 (page 95) — Users are asked to run a tool to convert a shapefile into a geodatabase
feature class. They will not use the Copy Features tool (currently described in the instructions).
They will use the Feature Class To Feature Class tool. See the screenshot.

Exercise 3b: Incorporate tabular data
Section: Apply informative symbols
•

Step 4 (page 107) — Users are asked to choose the yellow-to-red color ramp but are not told
how to identify that specific color ramp. They should check the Show Names check box in the
Symbology pane to see the names of all available color ramps, scroll through the list, and
choose the desired option.

Exercise 3d: Connect spatial datasets
Section: Spatially join data
•

Step 8 (page 134) — Users are asked to select the Illinois_cnty_SpatialJoin layer in the Contents
pane to add labels. But the layer they need is called c2010_SpatialJoin, as shown in various
symbology screenshots.

Chapter 4
Creating and editing spatial data
Exercise 4a: Build a geodatabase
Section: Map x,y points
•

Step 5 (page 151) — Users are asked to click Toolboxes in the Geoprocessing pane. The UI has
been slightly modified. The instructions should read as follows:
➢ In the Geoprocessing pane, click the Back arrow twice, and then click Toolboxes.

Exercise 4b: Create features
Section: Configure snapping options
•

Step 8 (page 161) — Users are asked to display the edit sketch of a selected feature. But the UI
does not specifically label the tool gallery as such. To open the Modify Features pane, the
instructions should read as follows:
➢ On the Edit tab, in the Tools group, click the Vertices button to display the selected feature’s
edit sketch.

Exercise 4c: Modify features
Section: Add map notes
•

Step 6 (page 184) — Users are asked to draw two lines over a set of new waterline features and
insert vertices at designated points. If users are working off the results project provided in the
student data, they will not see the waterline feature that they created earlier in the chapter. But
this does not prevent users from completing the remainder of the steps in this chapter.

Chapter 5
Facilitating workflows
Exercise 5a: Manage a repeatable workflow using tasks
Section: Set up a project
•

Step 2 (page 193) — Users are asked to examine the Catalog pane. The instructions should read
as follows:
➢ Examine the Catalog pane by expanding the Folders and the Tasks folders and subfolders, as
shown in the graphic.

Section: Author a task
•

Step 9 (page 205) — Users are asked to enter parameters in the Task Designer. Specifically, the
instructions currently call for choosing ACLED_2010_2018_SouthSudan for Input Table. But this
name may not appear on the screen. Users should instead look for the name that they used
earlier to rename the layer (ACLED_2010_2018_SouthSudan was suggested as a possibility, but
users were encouraged to specify a name of their choice).

•

Step 10 (page 205) — Users are asked to close the Task Designer. But they should first click Done
to save the values they entered.

Exercise 5b: Create a geoprocessing model
Section: Define the data
•

Step 2 (page 208) — Users are asked to add a feature class called _2005_2018 to the map. The
name is incorrect. The correct name of the feature class is ACLED_2005_2018.

Section: Fill out the tool parameters
•

Step 2 (page 215) — Users are asked to enter parameters for the Select Layer By Attribute tool.
The UI of the expression builder has changed. The instructions should read as follows:
➢ For the first parameter, select ACLED_2010_2018_Rwanda. Maintain the default selection
type (New selection). For Expression, click New expression. Use the drop-down boxes to
build the following expression:
EVENT_TYPE is Equal to Violence against civilians.

•

Step 3 (page 215) — Users are asked to finish building their expression and then close the Select
Layer By Attribute tool. The UI of the expression builder has changed—it is no longer necessary
to click Add. The instructions should read as follows:
➢ Click OK.

•

Step 5 (page 216) — Users are asked to enter the parameters for the Summary Statistics tool.
The current instructions for the value for Input Table generate a model input–output error. The
instructions should read as follows:
➢ For Input Table, select ACLED_2010_2018_Rwanda:2.

Section: Run the model
•

Step 5 (page 219) — Users are asked to open a new results table to review the data. After
reviewing the data and answering the question, users should close the
ACLED_Rwanda_Statistics table before proceeding.

Exercise 5c: Run a Python command and script tool
Section: Define the data
•

Step 1 (page 224) — Users are asked to either open or continue working in the project. But the
two layers listed are not the correct names of the actual layers in the project. The correct names
are ACLED_2010_2018_SouthSudan and ACLED_2010_2018_Rwanda.

Section: Execute a command using Python
•

Step 9 (page 228) — Users are asked to change the output file name in the Python window. The
instructions contain a typo. The correct file name should be ACLED_2010_2018_Nigeria2.lyrx.

Section: Use a custom script tool
•

Tip (page 232) — Users are told to manually edit the “env.workspace = ” line in the Select and
Summarize custom script, if necessary. They should also edit the year span in the InputFile line,
if necessary, to read as follows:
# Prompt the user for the name of the input layer
ACLED_2010_2018_InputFile = arcpy.GetParameterAsText(0)
After editing the script in edit mode, click File > Save.

Chapter 6
Collaborative mapping
Exercise 6a: Prepare a database for data collection
Section: Set up a domain
•

Step 2 (page 240) — Users are asked to click Design > Domains in the Catalog pane. The UI has
been slightly modified. The graphic in the exercise is correct, but the instructions should read as
follows:
➢ In the Catalog pane, click Project, and expand Databases. Right-click TreeInventory.gdb and
click Domains.

Section: Set up feature class fields
•

Step 1 (page 242) — Users are asked to expand the TreeInventory database, but the incorrect
pane location is given. The instructions should read as follows:
➢ In the Catalog pane, click Project, and expand the TreeInventory database. Right-click Trees
and go to Design > Fields.

Section: Publish features
•

Step 3 (page 248) — Users are asked to type item details in a layer being shared, but the
incorrect field name is given. The graphic is correct, but the instructions should read as follows:
➢ For Summary, type A tree inventory layer for data collection.

•

Step 7 (page 250) — Users are asked to close the Share Web Layer pane, but the correct name
of the pane is Share As Web Layer.

Chapter 7
Geoenabling your project
Exercise 7a: Prepare project data
Section: Symbolize using graduated colors
•

Step 7 (page 293) — Users are asked to change the outline color symbology of a symbol. The UI
has been simplified, so the instructions should read as follows:
➢ Click the More down arrow and click Format all symbols. Click Properties and change the
outline color to Soapstone Dust. Click Apply.

Exercise 7b: Geocode location data
Section: Geocode addresses
•

Step 4 (page 300) — Users are asked to browse to an address locator that they created earlier,
but the navigational instructions assume that all students stored the tool in the same location.
The instructions should read as follows:
➢ Browse to your project folder (Project > Folders > CommunityHousing), find the address
locator that you created earlier (Housing_Address_Locator), and select it.

Exercise 7c: Use geoprocessing tools to analyze vector data
Section: Create buffers
•

Step 6 (page313) — Users are asked to type parameters for the Multiple Ring Buffer tool. One
field name is incorrect, so the instructions should read as follows:
➢ In the Buffer Unit drop-down list, select Miles.

Section: Calculate distances
•

Step 9 (page 324) — Users are asked to set parameters in the Measure tool. The UI has been
modified, so the instructions should read as follows:

➢ In the upper-left corner of the map, in the Measure Distance window, click the options
down arrow and click Feet.

•

Step 10 (page 324) — Users should be instructed to exit the tool they’re using, as follows:
➢ To exit the Measure tool, close the Measure Distance window or click another tool in the
ribbon (such as Explore).

Section: Select by location
•

Step 5 (page 327) — Users are asked to export selected features and are shown a graphic of the
Copy Features tool. The Feature Class to Feature Class tool is now used to export the features
that users selected by location earlier.

Section: Intersect layers
•

Step 2 (page 330) — Users are asked to type parameters in the Intersect tool. The graphic
incorrectly shows the output feature class as city_boundary_Intersect. The correct output
feature class name should be city_census_tracts, as listed in the instructions.

•

Step 7 (page 331) — Users are asked to type parameters in the Apply Symbology From Layer
tool, but are not told when to run the tool. They should run the tool after completing step 7.

•

Step 8 (page 332) — Add the following tip after step 8:

➢ To see all the buffer rings, you may need to move the buffers directly above the
city_census_tracts layer in the Contents pane.

Chapter 8
Analyzing spatial and temporal patterns
Exercise 8a: Create a kernel density map
Section: Select by attributes
•

Step 5 (page 339) — Users are asked to enter parameters in the Select Layer By Attribute tool.
The UI has been updated. The instructions should read as follows:
➢ In the Select Layer By Attribute tool parameters, for Input Rows, select crime. For Selection
type, select New selection.

•

Step 6 (page 339) — The instructions should read as follows:
➢ Under Expression, click New expression.

•

Step 7 (page 339) — Users no longer need to click Add after building the expression in this step.

•

Step 8 (page 339) — Users only need to click Add Clause once, not a second time, and use this
corrected graphic as a guide:

•

Step 12 (page 340) — Users are asked to create a feature layer from a selection. To do so, they
will use the Feature Class to Feature Class tool, not the Copy Features tool. The instructions and
graphic should be as follows:
➢ Point to the Output Location box to see the default output location—the project
geodatabase. Maintain this path but change the Output Feature Class name to robbery.

Exercise 8b: Perform a hot spot analysis
Section: Run the Optimized Hot Spot Analysis tool
•

Step 8 (page 349) — Add the following tip after the step:
➢ If you do not see a pop-up window for the cell you selected, click the Explore tool down
arrow and choose Visible Layers.

Section: Visualize a space-time cube
•

Step 2 (page 352) — This step is unnecessary and should be omitted.

•

Step 3 (page 352) — The instructions should read as follows:
➢ In the Contents pane, under Elevation Surfaces, remove the elevation services that are
being used by default.

Exercise 8c: Explore the results in 3D
Section: Switch to a local view
•

Step 6 (page 363) — Users should ignore this step, which tells them to close the Map Properties
dialog box for the scene. They need the dialog box for step 7 (viewing the custom extent
option).

Chapter 10
Presenting your project
Exercise 10a: Apply detailed symbology
Section: Create a definition query
•

Step 4 (page 434) — Users are asked to create a query expression to select certain features. The
query builder UI has changed, so the instructions should read as follows:
➢ In the Definition Query frame, click New definition query, and create the following
expression: Technology_of_Transmission is Equal to 70 – Terrestrial Fixed Wireless – Un
licensed. Click Add Clause.

Exercise 10b: Label features
Section: Label features using the Maplex Label Engine
•

Step 6 (page 448) — Users are asked to build a query. It’s no longer necessary to click Add
before applying. The instructions should read as follows:
➢ On the SQL Query tab, build a query in which PublicWifi is equal to Unknown. Click Apply.

Exercise 10c: Create a page layout
Section: Insert map frames
•

Step 1 (page 457) — Users are instructed to insert a specific map frame from the layout gallery.
The functionality has changed somewhat, so the instructions should read as follows:
➢ On the Insert tab, in the Map Frames group, click the Map Frame down arrow, and select
the map frame directly to the right of Default Extent in the Community Anchor Institutes
group in the gallery. (The map frame you want probably has the map scale as its name.)

•

Add the following step after step 1:
➢ Draw a rectangle on the empty layout to add the Community Anchor Institutes map.

•

Step 11 (page 459) — After performing this step, users should click the Layout link again to exit
the activated mode before proceeding to rename the map frames.

Section: Insert a legend element
•

Step 6 (page 462) — Users are instructed to modify width and height in the Format Legend
pane. The correct name of the pane is the Format Legend Item pane. (The Format Legend pane
is a different pane that users will encounter in a few steps.)

Section: Insert dynamic text, a title, and rectangles
•

Step 1 (page 470) — After selecting Spatial Reference from the Dynamic Text group, users
should draw a rectangle anywhere on the layout to place the text group before converting it to a
graphic in the next step.

Section: Export a layout to a PDF
•

Step 3 (page 476) — Users are asked to rename their map layout and then export it. Directly
after renaming their map layout, users should do the following:
➢ For Save as type, select PDF, and then click Export Options.

